Defect #34167

when i put if condition and update any field the if condition field lost data

Added by moustafa elbeda about 1 month ago. Updated 16 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:

Description

$(document).on('click', '.update', function() {
var user_id = $(this).attr("id");
$.ajax({
    url: "fetch_single.php",
    method: "POST",
    data: {
        user_id: user_id
    },
    dataType: "json",
    success: function(data) {
        $('#userModal').modal('show');
        $('#name').val(data.name);
        $('#status_id').val(data.status_id);
        $('#note').val(data.note);
        $('#note_tow').val(data.note_tow);
        $('#note2').val(data.note2);
        $('#note3').val(data.note3);
        $('#payment').val(data.payment);
        $('#ntg_no').val(data.ntg_no);
        $('.modal-title').text("تعديل الحالة");
        $('#user_id').val(user_id);
        $('#action').val("Edit");
        $('#operation').val("Edit");

        if ($("#note").val() !== '') {
            $("#note").prop("disabled", true);
        } else {

            $("#note").prop("disabled", false);
        }
    }
});
});

I am using a JQuery model form with Ajax to allow users to enter new values and update in text area I put condition statement depend on field value NULL OR NOT NULL after success but when update any field
the condition field(note) lost data

History

#1 Updated by Go MAEDA about 1 month ago

  • Description updated (diff)

#2 Updated by moustafa elbeda about 1 month ago

when i put if statement filed note is cleared after update any field

#3 Updated by moustafa elbeda about 1 month ago

0

the issue is solved replace disable to readonly

#4 Updated by Go MAEDA 24 days ago

  • Category deleted (Issues)
  • Resolution set to Invalid

Please use forums for questions. Issues are used to report a bug, suggesting a new feature, or submitting a patch. Reading How to request help may be helpful for you.

#5 Updated by Go MAEDA 16 days ago

  • Status changed from New to Closed

Also available in: Atom PDF