Defect #34194

Tags plugin does not work in Dockerized Redmine

Added by Ralph Brecheisen about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:4.1.1

Description

Hi,

I'm running Redmine 4.1.1 as a Docker container on my server. I'm try to install the Tags plugin by copying the ZIP file redmineup_tags-2_0_8-light.zip and placing it in the plugins directory. When I restart the container the plugin seems to be installed automatically but when I try to configure it in the Settings page, I get a page error. Also every issue page I try to view gets the same error page, probably because the page tries to load the plugin.

When I explicitly run the following statement inside the Docker container:

- bundle install
- bundle exec rake redmine:plugins NAME=redmineup_tags RAILS_ENV=production

I get the errors below. When I add the 'pg' to the Gemfile, part of the error is gone but I'm getting other errors in return.

Anyone an idea why this doesn't work?

Ralph

root@213f9e087e8b:/usr/src/redmine/plugins/redmineup_tags# bundle exec rake redmine:plugins NAME=redmineup_tags RAILS_ENV=production
(in /usr/src/redmine)
rake aborted!
LoadError: Error loading the 'postgresql' Active Record adapter. Missing a gem it depends on? pg is not part of the bundle. Add it to your Gemfile.
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/postgresql_adapter.rb:4:in `<top (required)>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `block in require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/connection_specification.rb:191:in `spec'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/abstract/connection_pool.rb:975:in `establish_connection'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_handling.rb:60:in `establish_connection'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/railtie.rb:136:in `block (2 levels) in <class:Railtie>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:71:in `instance_eval'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:71:in `block in execute_hook'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:62:in `with_execution_control'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:67:in `execute_hook'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:43:in `block in on_load'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:42:in `each'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:42:in `on_load'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/railtie.rb:132:in `block in <class:Railtie>'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:32:in `instance_exec'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:32:in `run'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:61:in `block in run_initializers'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:60:in `run_initializers'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:361:in `initialize!'
/usr/src/redmine/config/environment.rb:16:in `<top (required)>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `block in require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:337:in `require_environment!'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:520:in `block in run_tasks_blocks'
/usr/src/redmine/lib/tasks/redmine.rake:57:in `block (2 levels) in <top (required)>'
/usr/local/bundle/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'

Caused by:
Gem::LoadError: pg is not part of the bundle. Add it to your Gemfile.
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/postgresql_adapter.rb:4:in `<top (required)>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `block in require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/connection_specification.rb:191:in `spec'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_adapters/abstract/connection_pool.rb:975:in `establish_connection'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/connection_handling.rb:60:in `establish_connection'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/railtie.rb:136:in `block (2 levels) in <class:Railtie>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:71:in `instance_eval'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:71:in `block in execute_hook'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:62:in `with_execution_control'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:67:in `execute_hook'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:43:in `block in on_load'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:42:in `each'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/lazy_load_hooks.rb:42:in `on_load'
/usr/local/bundle/gems/activerecord-5.2.4.2/lib/active_record/railtie.rb:132:in `block in <class:Railtie>'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:32:in `instance_exec'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:32:in `run'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:61:in `block in run_initializers'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/initializable.rb:60:in `run_initializers'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:361:in `initialize!'
/usr/src/redmine/config/environment.rb:16:in `<top (required)>'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `block in require'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:257:in `load_dependency'
/usr/local/bundle/gems/activesupport-5.2.4.2/lib/active_support/dependencies.rb:291:in `require'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:337:in `require_environment!'
/usr/local/bundle/gems/railties-5.2.4.2/lib/rails/application.rb:520:in `block in run_tasks_blocks'
/usr/src/redmine/lib/tasks/redmine.rake:57:in `block (2 levels) in <top (required)>'
/usr/local/bundle/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => redmine:plugins:migrate => environment
(See full trace by running task with --trace)

History

#1 Updated by Go MAEDA about 1 month ago

Please use forums for questions. Issues are used to report a bug, suggesting a new feature, or submitting a patch. Reading How to request help may be helpful for you.

#2 Updated by Go MAEDA about 1 month ago

  • Category deleted (Plugin API)
  • Status changed from New to Closed
  • Resolution set to Invalid

Also available in: Atom PDF