Defect #36794

Issue copying ignores workflow rules

Added by Dmitry Makurin 3 months ago. Updated 3 months ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution: Affected version:

Description

Issue.copy ignores rules defined by workflow for status New (new issue form).

A simple example.

Let's say we have an issue:

Project: eCookBook
Tracker: Bug
Status: Closed
Category: Print

Create a workflow rule where for tracker Bug and role Manager field Category is read-only on status New.

User with given role presses the Copy button. New issue form is shown, as expected by workflow there is no Category field because it is not editable by user.

Press create and see that field Category was succesfully copied even though user can't edit it.

Also steps to reproduce on a test database with loaded fixtures:

1. Go to Administration - Workflow - Fields permissions
2. Select role Manager, tracker Bug press edit
3. Make Float field read-only for status New
4. Log as jsmith and copy issue#1
5. There is no Float field on form
6. Save the issue and see that Float field was copied

36794.patch Magnifier (4.49 KB) Dmitry Makurin , 2022-03-17 16:46

History

#1 Updated by Dmitry Makurin 3 months ago

Patch with fix 36794.patch

Also available in: Atom PDF