Patch #36795

Set the minimum required version of ROTP gem to 5.0.0

Added by Go MAEDA 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gems support
Target version:4.2.5

Description

Two-factor authentication does not work if ROTP prior to 5.0.0 is installed (see Got 500 error when enabling 2FA.). The attached patch sets the minimum required version of ROTP gem.

$ ruby test/integration/twofa_test.rb
Run options: --seed 18716

# Running:

F

Failure:
TwofaTest#test_should_require_twofa_setup_when_required_for_administrators [test/integration/twofa_test.rb:51]:
Expected response to be a <3XX: redirect>, but was a <500: Internal Server Error>

rails test test/integration/twofa_test.rb:34

F

Failure:
TwofaTest#test_should_require_twofa_setup_when_required_by_group [test/integration/twofa_test.rb:76]:
Expected response to be a <3XX: redirect>, but was a <500: Internal Server Error>

rails test test/integration/twofa_test.rb:55

.
.
.

rotp-version.patch Magnifier (330 Bytes) Go MAEDA, 2022-03-18 00:34

Associated revisions

Revision 21462
Added by Go MAEDA 3 months ago

Set the minimum required version of ROTP gem to 5.0.0 (#36795).

Revision 21486
Added by Go MAEDA 3 months ago

Merged r21462 from trunk to 4.2-stable (#36795).

History

#1 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch.

#2 Updated by Go MAEDA 3 months ago

  • Target version changed from 5.0.0 to 4.2.5

Also available in: Atom PDF