Defect #3903

Error loading default data "permissions was supposed to be a Array, but was a String"

Added by Luca Pireddu over 11 years ago. Updated almost 11 years ago.

Status:ClosedStart date:2009-09-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:No feedback Affected version:

Description

When installing Redmine trunk, I run

rake redmine:load_default_data RAILS_ENV="production"

with the result

Error: permissions was supposed to be a Array, but was a String

I also tried with the stable branch, but I still got an error where "but was a String" instead said "but was a FalseClass"

 ./script/about
About your application's environment
Ruby version              1.8.7 (i486-linux)
RubyGems version          1.3.5
Rack version              1.0
Rails version             2.3.4
Active Record version     2.3.4
Active Resource version   2.3.4
Action Mailer version     2.3.4
Active Support version    2.3.4
Application root          /home/user/Projects/redmine_stuff/trunk
Environment               development
Database adapter          sqlite3
Database schema version   20090704172358

History

#1 Updated by Jean-Philippe Lang over 11 years ago

I can't reproduce with trunk@r2907 and a sqlite3 database.

#2 Updated by Jean-Philippe Lang over 11 years ago

  • Status changed from New to Closed
  • Resolution set to No feedback

#3 Updated by minkbear minkbear almost 11 years ago

I have the same problem and try to solve it. so I met strange texts format in Roles.Permission table below:

--- 
- :view_issues
- :view_gantt
- :view_calendar
- :view_time_entries
- :view_documents
- :view_wiki_pages
- 
:view_wiki_edits
- :view_files
- :browse_repository
- :view_changesets

if I change to:

--- 
- :view_issues
- :view_gantt
- :view_calendar
- :view_time_entries
- :view_documents
- :view_wiki_pages
- :view_wiki_edits
- :view_files
- :browse_repository
- :view_changesets

The error say "Error: permissions was supposed to be a Array, but was a String". My redmine got back to work fine again no error any more.
So I inform your team to be FYI.

Also available in: Atom PDF