Feature #4318

I can't receive mail notification for news and issue

Added by J.K Wang about 12 years ago. Updated almost 3 years ago.

Status:ClosedStart date:2009-12-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Cant reproduce

Description

I can't receive mail notification.
the following log:

Processing IssuesController#new (for 192.168.0.66 at 2009-12-02 16:08:10) [POST]
168600 Session ID: a6f463b5c4a3a201ea24f955a70cb861
168601 Parameters: {"project_id"=>"ppms", "commit"=>"å<88><9b>建", "action"=>"new", "controller"=>"issues", "issue"=>{"start_date"=>"2009-12-02", "estimate d_hours"=>"", "priority_id"=>"4", "subject"=>"æµ<8b>è¯<95>æ<8f><90>交é<97>®é¢<98>é<82>®ä»¶æ<8f><90>é<86><92>ã<80><82>", "description"=>"æµ<8b>è¯<95>æ< 8f><90>交é<97>®é¢<98>é<82>®ä»¶æ<8f><90>é<86><92>", "tracker_id"=>"2", "done_ratio"=>"0", "due_date"=>"", "assigned_to_id"=>"99", "status_id"=>"1"}, "a ttachments"=>{"1"=>{"description"=>"", "file"=>""}}}
168602 Sent mail to
168603 Redirected to http://192.168.1.11:3000/issues/show/122
168604 Completed in 0.15848 (6 reqs/sec) | DB: 0.07384 (46%) | 302 Found [http://192.168.1.11/projects/ppms/issues/new]

Processing NewsController#new (for 192.168.0.66 at 2009-12-02 16:06:44) [POST]
168569 Session ID: a6f463b5c4a3a201ea24f955a70cb861
168570 Parameters: {"project_id"=>"ppms", "commit"=>"å&lt;88&gt;&lt;9b&gt;建", "action"=>"new", "controller"=>"news", "news"=>{"title"=>"æµ&lt;8b&gt;è¯&lt;95&gt;æ&lt;96&gt;°é&lt;97&gt;»é&lt;82&gt;® 件æ&lt;8f&gt;&lt;90&gt;é&lt;86&gt;&lt;92&gt;ã&lt;80&gt;&lt;82&gt;", "description"=>"http:// 192.168.1.11/projects/ppms/news/new", "summary"=>""}}
168571 Sent mail to
168572 Redirected to http://192.168.1.11:3000/projects/ppms/news
168573 Completed in 0.06335 (15 reqs/sec) | DB: 0.00738 (11%) | 302 Found [http://192.168.1.11/projects/ppms/news/new]

History

#1 Updated by Jean-Philippe Lang about 12 years ago

Please read SubmittingBugs and FAQ.

#2 Updated by Daniel Sintaj almost 12 years ago

Very nice FAQ entry, indeed.

But what about an option when:

=> If you do recieve the testing email, but notifications from your issues aren't sent at all.

Debug is enabled, but no useful information provided.

I still haven't solved it - http://www.redmine.org/issues/3989 even though it is marked as "Closed."

#3 Updated by J.K Wang almost 12 years ago

$sudo ruby script/about
About your application's environment
Ruby version              1.8.6 (i486-linux)
RubyGems version          1.3.5
Rails version             2.1.2
Active Record version     2.1.2
Action Pack version       2.1.2
Active Resource version   2.1.2
Action Mailer version     2.1.2
Active Support version    2.1.2
Edge Rails revision       unknown
Application root          /mnt/MD1000/sites/redmine
Environment               development
Database adapter          mysql

$psql --version
psql (PostgreSQL) 8.3.8

redmine version 0.8.4

email.yml

production:
  delivery_method: :smtp
  smtp_settings:
    address: 192.168.0.254
    port: 25
    domain: mydomain.com
    authentication: :login
    user_name: username
    password: ******

database.yml

production:
  adapter: postgresql
  database: redmine
  host: localhost
  username: XXX
  password: XXX
  encoding: utf8

tracelog:

Processing IssuesController#new (for 192.168.0.66 at 2009-12-02 16:08:10) [POST]
168600 Session ID: a6f463b5c4a3a201ea24f955a70cb861
168601 Parameters: {"project_id"=>"ppms", "commit"=>"å<88><9b>建", "action"=>"new", "controller"=>"issues", "issue"=>{"start_date"=>"2009-12-02", "estimate d_hours"=>"", "priority_id"=>"4", "subject"=>"æµ<8b>è¯<95>æ<8f><90>交é<97>®é¢<98>é<82>®ä»¶æ<8f><90>é<86><92>ã<80><82>", "description"=>"æµ<8b>è¯<95>æ< 8f><90>交é<97>®é¢<98>é<82>®ä»¶æ<8f><90>é<86><92>", "tracker_id"=>"2", "done_ratio"=>"0", "due_date"=>"", "assigned_to_id"=>"99", "status_id"=>"1"}, "a ttachments"=>{"1"=>{"description"=>"", "file"=>""}}}
168602 Sent mail to
168603 Redirected to http://192.168.1.11:3000/issues/show/122
168604 Completed in 0.15848 (6 reqs/sec) | DB: 0.07384 (46%) | 302 Found [http://192.168.1.11/projects/ppms/issues/new]
Processing NewsController#new (for 192.168.0.66 at 2009-12-02 16:06:44) [POST]
168569   Session ID: a6f463b5c4a3a201ea24f955a70cb861
168570   Parameters: {"project_id"=>"ppms", "commit"=>"å&lt;88&gt;&lt;9b&gt;建", "action"=>"new", "controller"=>"news", "news"=>{"title"=>"æµ&lt;8b&gt;è¯&lt;95&gt;æ&lt;96&gt;°é&lt;97&gt;»é&lt;82&gt;®       件æ&lt;8f&gt;&lt;90&gt;é&lt;86&gt;&lt;92&gt;ã&lt;80&gt;&lt;82&gt;", "description"=>"http://       192.168.1.11/projects/ppms/news/new", "summary"=>""}}
168571 Sent mail to
168572 Redirected to http://192.168.1.11:3000/projects/ppms/news
168573 Completed in 0.06335 (15 reqs/sec) | DB: 0.00738 (11%) | 302 Found [http://192.168.1.11/projects/ppms/news/new]

#4 Updated by J.K Wang almost 12 years ago

I try to update redmine to 0.8.7 , but I have the same problem.

#5 Updated by J.K Wang almost 12 years ago

  • Assignee set to Jean-Philippe Lang

I think this problem is about database. when I use "RAILS_ENV=production rake db:migrate" to create a database I can't receive the mail notification. but if I import data from postgresql to mysql use "DBConvert for MySQL & PostgreSQL" (because the tool is not registed ,only 50 line for each table), I can received the mail notifications.

#6 Updated by shubham chakraborty almost 12 years ago

What is the solution to this????
Even i cant receive email notifications?
I switched to redmine because it had better interface and usability.
But without emails, its of no use.

#7 Updated by Etienne Massip over 10 years ago

  • Assignee deleted (Jean-Philippe Lang)

Quite an old post, did you manage to make it work ?

#8 Updated by Ho Tak over 10 years ago

Etienne Massip wrote:

Quite an old post, did you manage to make it work ?

Hi

I have the same problem, could anyone have a look on it please?

Thanks.

#9 Updated by Etienne Massip over 10 years ago

See SubmittingBugs and give all asked for informations.

And have a look at the definition of the column mail_notification in the users tabe of the db, should be a varchar(255).

#10 Updated by Ho Tak over 10 years ago

Hi,

I think I have misunderstanding on the mail notification thing, I don't know the submission of code(activity), will not classify as "updated of issue"
I have been so stupid, and sorry for the inconvenience.

Thanks a lot for the quick response and help!

Tak.

#11 Updated by Go MAEDA almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Also available in: Atom PDF