Defect #5784

Mail subject is cutting on MS Exchange 2007, 2010 after 256 character. (RFC2047)

Added by Alexander Britov over 11 years ago. Updated about 10 years ago.

Status:ClosedStart date:2010-06-30
Priority:HighDue date:
Assignee:Alexander Britov% Done:

0%

Category:Email notifications
Target version:-
Resolution:Invalid Affected version:

Description

Redmine - does not follow the RFC2047, as the line should not be longer than 75 character.

The following example shows how a large line should be:
Content-Type: text/plain; name=
"=?iso-2022-jp?B?GyRCJCIkJCQmJCgkKiQrJC0kLyQxJDMkNSQ3JDkkOyQ9JD8bKEI=?=
=?iso-2022-jp?B?GyRCJEEkRCRGJEgkSiRLJEwkTSROJE8kUiRVJFgkWyReJF8bKEI=?=
=?iso-2022-jp?B?GyRCJGAkYSRiJGQkZiRoJGkkaiRrJGwkbSRvJHIkcyMxIzIbKEI=?=
=?iso-2022-jp?B?GyRCIzMjNCM1IzYjNyM4IzkjMBsoQi50eHQ=?="

The following RFC describe how the message header should be for Non-ASCII Text
MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII Text
http://www.faqs.org/rfcs/rfc2047.html

encoded-word = "=?" charset "?" encoding "?" encoded-text "?="

Example for Error.

Initial data:
- Sender's mail client - from Redmine.
!!==> Subject: contains 81 (!!!) character in Russian encoding.
This was only the letters without any characters, spaces, digits, etc.
- Recipient's mail client: OLK 2007 (12.0.6316.5000) SP1.
- Mailbox server: Exchange 2007 SP1
!!==> Field Subject shows CORRECTLY in Outlook 2007.
Subject: =?koi8-r?Q?=C6=CC=C4=C4=D0=C1=CF=CC=C4=C1=D7=D0=DB=DD=C5=CB=D6=C4=CD=D9=D7=CF=D0=DA=DD=D5=CB=C4=D9=CC=D7=CF=D0=CC=C1=D0=CF=C4=CC=D7=C1=CF=C4=CC=D9=D7=CF=C1=DB=DD=D5=C1=CF=D7=D9=C4=C1=CC=CF=CB=D5=C3=C4=DB=C1=C4=CC=D0=D2=CC=C1=CF=D0=D5=C3=C4=CB=CF=DB=C9?=


Related issues

Related to Redmine - Defect #18864: troubles in email notifications (Redmine 2.5.2.stable, r... Closed

History

#1 Updated by Roland Discein over 11 years ago

  • Status changed from New to Resolved
  • You can change this limitation up to 4096 symbols.

On exchange server you should do the following:

  1. cd in bin directory of exchange installation path
  2. open file EdgeTransport.exe.config with notepad
    <configuration>
    
    <runtime>
    
    <gcServer enabled="true" />
    
    </runtime>
    
    <appSettings>
    
    <add key="AgentLogEnabled" value="true" />
    
    <add key="ResolverRetryInterval" value="30" />
    
    . . . . . .
    
    </configuration>
    
  3. Add this lines between "<configuration>" and "<runtime>"(don't change the "version" field value):
    <configSections>
    
    <section name="CTS" type="Microsoft.Exchange.Data.Internal.CtsConfigurationSection, Microsoft.Exchange.Data.Common, PublicKeyToken=31bf3856ad364e35, version=8.0.681.0, culture=neutral"/>
    
    </configSections>
    
    <CTS>
    
    <MimeLimits>
    
    <MaximumEncodedWordLength Value="4096"/>
    
    </MimeLimits>
    
    </CTS>
    
  4. Restart Exchange Transport Service

BTW, this is not redmine's defect, this is feature of exchange. Be careful when submitting bugs.


The same in russian:

Redmine отсылает разные уведомления по почте.
Заголовок Subject в случае наличия не ASCII символов(русских букв) кодируется при отправке в utf-8.
Почтовые клиенты понимают это и отображают по-русски.

Тема обрезается до 255 символов, почтовый клиент не видит "?=" в конце строки и не декодирует ее.


  • Чтобы увеличить длину заголовков до 4096:
  1. Перейдите в каталог bin где у вас установлен Exchange
  2. Откройте в блокноте EdgeTransport.exe.config
    <configuration>
    
    <runtime>
    
    <gcServer enabled="true" />
    
    </runtime>
    
    <appSettings>
    
    <add key="AgentLogEnabled" value="true" />
    
    <add key="ResolverRetryInterval" value="30" />
    
    . . . . . .
    
    </configuration>
    
  3. Добавьте эти строчки между <configuration> и <runtime> (поле "version" менять не надо) :
    <configSections>
    
    <section name="CTS" type="Microsoft.Exchange.Data.Internal.CtsConfigurationSection, Microsoft.Exchange.Data.Common, PublicKeyToken=31bf3856ad364e35, version=8.0.681.0, culture=neutral"/>
    
    </configSections>
    
    <CTS>
    
    <MimeLimits>
    
    <MaximumEncodedWordLength Value="4096"/>
    
    </MimeLimits>
    
    </CTS>
    
  1. перезапустите службу Exchange Transport Service.

И вообще, это не баг redmine, а фича exchange.

#2 Updated by Felix Schäfer over 11 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Closing as being a "feature" of exchange, not a bug of redmine (in any case, redmine uses the mail handling libraries provided by ruby and/or rails, so any error would have to be reported there rather than here).

Roland, thanks for what looks like a good explanation :-)

#3 Updated by Vitaliy Boyarenko about 10 years ago

  • Status changed from Closed to Reopened
  • Assignee set to Alexander Britov

Я столкнулся с похожей проблемой, при создании задачи с темой более 12 русских символов на почту приходят такие вещи (=?utf-8?Q?=5B=D0=A2=D0=95=D0=A1=D0=A2_=D0=A2=D0=95=D0=A1=D0=A2_=D0=A2=D0=95=D0=A1=D0=A2_=2D_=D0=9E=D1=88=D0=B8=D0=B1=D0=BA=D0=B0_=23=31=36=5D_=28=D0=9D=D0=BE=D0=B2=D0=B0=D1=8F=29_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D...)
если меньше или 12 то все нормально ([ТЕСТ ТЕСТ ТЕСТ - Ошибка #17] (Новая) ва ва ва ва )
непонимаю что нужно сделать что бы все было нормально

#4 Updated by Vitaliy Boyarenko about 10 years ago

Vitaliy Boyarenko wrote:

Я столкнулся с похожей проблемой, при создании задачи с темой более 12 русских символов на почту приходят такие вещи (=?utf-8?Q?=5B=D0=A2=D0=95=D0=A1=D0=A2_=D0=A2=D0=95=D0=A1=D0=A2_=D0=A2=D0=95=D0=A1=D0=A2_=2D_=D0=9E=D1=88=D0=B8=D0=B1=D0=BA=D0=B0_=23=31=36=5D_=28=D0=9D=D0=BE=D0=B2=D0=B0=D1=8F=29_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D0=B0_=D0=B2=D...)
если меньше или 12 то все нормально ([ТЕСТ ТЕСТ ТЕСТ - Ошибка #17] (Новая) ва ва ва ва )
непонимаю что нужно сделать что бы все было нормально

Почтовый сервер Exchange 2007

#5 Updated by Etienne Massip about 10 years ago

  • Status changed from Reopened to Closed

Please speak English here.

#6 Updated by Toshi MARUYAMA almost 7 years ago

  • Related to Defect #18864: troubles in email notifications (Redmine 2.5.2.stable, russian text) added

Also available in: Atom PDF