Project

General

Profile

Actions

Feature #7269

closed

Sort versions by version numbers x.y.z{z} instead of alphabetically

Added by Darni Jules about 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Roadmap
Target version:
-
Start date:
2011-01-10
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Example:

1.0.1
1.0.10
1.0.2
1.0.3


Related issues

Has duplicate Redmine - Defect #8653: Version name alphanumeric sortingClosed2011-06-20

Actions
Is duplicate of Redmine - Feature #6881: Version numbering sortNew2010-11-13

Actions
Actions #1

Updated by Bruno Medeiros about 13 years ago

I'ts probably due to an alphabetical sort.

Actions #2

Updated by Bruno Medeiros about 13 years ago

You can assign dates to your versions, it's the first field used to sort.

Actions #3

Updated by Darni Jules about 13 years ago

I don't know the release date ahead of time, which is apparently what this date is used for (Due in X days). But I can use this as a workaround for the sorting.

Actions #4

Updated by Jean-Philippe Lang about 13 years ago

  • Tracker changed from Defect to Feature
  • Subject changed from x.y.z{z} versions not sorted correctly in roadmap to Sort versions by version numbers x.y.z{z} instead of alphabetically
Actions #5

Updated by James Byrne about 13 years ago

Would it not be more useful to simply allow dynamic sorting both int settings/versions page and the Roadmap page? That way people can choose whichever column is meaningful to them, version number or due date.

I am not too keen on sorting the version by number if that means enforcing strict numerical version numbers. We preface our versions with project strings and sometimes add suffixes. For example: P-01.001.0001.b12. It is simple enough to adopt a placeholder pattern for version numbers (##.###.####) such that alphabetic and numeric sorting amount to the same thing.

Actions #6

Updated by Etienne Massip almost 13 years ago

  • Category set to Roadmap
Actions #7

Updated by Daniel Albuschat almost 12 years ago

Actually, since we don't use numbers in versions at all (bug instead some fancy names), I'd prefer a custom sorting.
I can see how this should be a rare case and numerical sorting should be the default, but I'd still think this should be considered.

Actions #8

Updated by David Rahusen almost 11 years ago

+1

Actions #9

Updated by Toshi MARUYAMA almost 11 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate with #6881.

Actions

Also available in: Atom PDF