Defect #7310

REST API Parameter GET /issues.xml?assigned_to=me doesn't work

Added by Matthias Neubert almost 11 years ago. Updated 12 months ago.

Status:ClosedStart date:2011-01-12
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Cant reproduce Affected version:1.1.0

Description

Hello,

I currently extend IntelliJ IDEAs Redmine PlugIn.

I want to query only for Issues which are assigned to one user.

e.g. Redmine-User-Login ist "mat"
so I hoped that GET /issues.xml?assigned_to=mat will deliver issues assigned to mat
Even if I try GET /issues.xml?assigned_to=MyFull%20Name it doesn't work.
It always returns the full issue list.

I also hope if you can fix this, that /projects/myproject1/issues.xml?assigned_to=mat
will work too.

Is this a bug in Redmine Rest API or what is my mistake

regards
Matthias

ps: I also tried to add the users api key to the request but that doesn't help

History

#1 Updated by Matthias Neubert almost 11 years ago

I found out that assigned_to_id works as expected!

But this doesn't help me that much, because the redmine plugins only knows
login, password and api key to do its requests.

a workaround would be to request the user id of a login, but I don't know if there is an REST call for this?!?

#2 Updated by Matthias Neubert almost 11 years ago

Update:
I found out that after authentification it is possible to get the current user:
/users/current.xml

-> so now I get the current user, extract its ID an use it in the issues request.
This is not the best solution but it works fine.

#3 Updated by Matthias Neubert almost 11 years ago

Unforunatly the mentioned user query only works with redmine 1.10.
in our production enviroment we still use 1.04, but we will change this soon

#5 Updated by Etienne Massip almost 11 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

#6 Updated by Mark Williamson over 10 years ago

  • Status changed from Closed to Reopened

This is not resolved.

I am using Redmine 1.1.0.stable.4764 (MySQL)

and the API query ?assigned_to=me returns all open issues assigned to anyone.

Can we get this fixed so we do not have to know the USERID [magic number]? It is a bad practice to pass magic numbers/user id's around to external entities requiring them to pass them back through the api.

?assigned_to_id=1234 is less desirable than
?assigned_to=me

#7 Updated by Jeffrey Clark over 9 years ago

/issues.xml?assigned_to_id=me appears to work for me in release 1.4.1.

#8 Updated by Go MAEDA 12 months ago

  • Status changed from Reopened to Closed
  • Resolution changed from Invalid to Cant reproduce

Also available in: Atom PDF