Project

General

Profile

Actions

Feature #8531

closed

Task's "assignee" should be specified by login instead of user ID

Added by Alex Last over 12 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
REST API
Target version:
-
Start date:
2011-06-04
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

I'm trying to create a task in Redmine using REST API and assign to a specific user.
I know the login name (or full name) of the user I want to assign the new task to, but I don't know the user database ID.

I could get all users from the server and find the required one, but this operation requires "Administrator" permission, which is a non-starter in many cases.

so, I propose to allow specifying the "task's assignee" with user login name and not just user ID.


Related issues

Is duplicate of Redmine - Feature #6721: Allow setting issue assignment by username via REST interfaceNew2010-10-21

Actions
Actions #1

Updated by Ian Epperson over 12 years ago

Duplicate of #6721

Actions #2

Updated by Etienne Massip over 12 years ago

  • Status changed from New to Closed

Closed as duplicate of #6721, thanks.

Actions #3

Updated by Etienne Massip over 12 years ago

  • Resolution set to Duplicate
Actions

Also available in: Atom PDF