Patch #9096

Fix redirection to non-latin wiki pages after logon

Added by Kirill Smirnov about 11 years ago. Updated about 1 month ago.

Status:ClosedStart date:2011-08-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-

Description

Consider a project having some wiki page with non-latin (russian) characters in URL: http://demo.redmine.org/projects/nonlatinwikipages/wiki/тестовая_страница

When non-authenticated user tries to access this page he is asked to complete logon procedure, after that he'll be redirected to default page ("My page" in my case) instead of wiki page.

This behaviour is caused by a ruby bug #21314: Uri parser not accepting non-Latin characters:
http://rubyforge.org/tracker/index.php?func=detail&aid=21314&group_id=426&atid=1698

Attached patch is mere a workaround for the bug.

uri_parse_workaround.diff Magnifier (743 Bytes) Kirill Smirnov, 2011-08-22 01:06

History

#1 Updated by Etienne Massip about 11 years ago

  • Category set to Wiki

#2 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Closed

Cannot reproduce in Redmine 5.0 with Ruby 3.1. Maybe the Ruby bug has already been fixed in recent versions.

Also available in: Atom PDF