Feature #9898

Wiki translation

Added by luigifab ! almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate

Description

If you have a wiki, you can't use the same page with differents translations.
You must create another page for each translation.

Example:
- Readme (in english)
- FrReadme (in french)

If one user access to your wiki with a « french browser », this user will see a redmine interface in french, but the content of the wiki will be in english.

This user must click on FrReadme link to access to the french version of the page.


I have a proposition, on wiki page editing, add a list like the « target version » list available on issue editing. By default, the selected language is the application default language.

Language list

So, if the administrator will translate his page in french, he can:
- he clic on the add button,
- he select a translation language,
- and redmine will show a blank textarea field.

Administrator manage one page.
User see the page in his language (if it available).

idea.png - Language list (7.04 KB) luigifab !, 2011-12-31 23:35


Related issues

Duplicates Redmine - Feature #9601: Multi language wiki New 2011-11-18

History

#1 Updated by Denny Schäfer almost 10 years ago

1+

#2 Updated by Etienne Massip almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #9601 (which might already be a duplicate).

Also available in: Atom PDF