Setting the email notification FROM parameter

Added by cyril Thibout almost 4 years ago

Hi

Even if I set in the redmine settings panel as the expeditor email, all the email notifications are sent with the FROM parameter set with the same email used for the authentication (defined in the configuration.yml file).

I must add I use the SMTP method as defined in the configuration.yml file:

smtp_settings:
delivery_method: :smtp
enable_starttls_auto: true
address: "smtp.gmail.com"
domain: "gmail.com"
port: 587
authentication: :plain
user_name: ""
password: "xxxxxx"

SO IS THERE A WAY TO SPECIFY A DIFFERENT EMAIL FOR THE 'FROM' parameter as the one used for authentication please?

Thanks

Cyril

Replies (7)

RE: Setting the email notification FROM parameter - Added by Go MAEDA almost 4 years ago

It is because you are using Gmail as an SMTP server. They rewrite the From field in messages.

RE: Setting the email notification FROM parameter - Added by cyril Thibout almost 4 years ago

Ok thanks for the explanation.

I used gmaim smtp because the office365 smtp is much much slower : we have to wait 2-4 seconds at each submission.
Maybe you know a way to make the email notification with o365 much faster ?

Meanwhile I revert back to the o365 settigns, at least the FROM parameter is right.

Thanks

Cyril

RE: Setting the email notification FROM parameter - Added by Go MAEDA almost 4 years ago

cyril Thibout wrote:

I used gmaim smtp because the office365 smtp is much much slower : we have to wait 2-4 seconds at each submission.
Maybe you know a way to make the email notification with o365 much faster ?

Have you tried asyncronous delivery setting?

RE: Setting the email notification FROM parameter - Added by cyril Thibout almost 4 years ago

No I didn't know

I tried

email_delivery:
async_smtp_settings:
delivery_method: :async_smtp
enable_starttls_auto: true
address: "smtp.office365.com"
port: 587
domain: "smtp.office365.com"
authentication: :login
user_name: ""
password: "xxxx"

but now in the redmine email notification test I get :

hostname "localhost" does not match the server certificate

Cyril

RE: Setting the email notification FROM parameter - Added by Go MAEDA almost 4 years ago

Maybe you have to describe "delivery_method" before "async_smtp_settings" like this.

  email_delivery:
    delivery_method: :async_smtp
    async_smtp_settings:
      enable_starttls_auto: true
      address: "smtp.office365.com" 
      port: 587
      domain: "smtp.office365.com" 
      authentication: :login
      user_name: "info@mydomain.com" 
      password: "xxxx" 

RE: Setting the email notification FROM parameter - Added by cyril Thibout almost 4 years ago

YES !!

THis is perfectly working: the email is sent without blocking redmine

thanks again

cyril

RE: Setting the email notification FROM parameter - Added by Go MAEDA almost 4 years ago

Thank you for the feedback. I am glad that I could be helpful to you!

(1-7/7)