Redmine upgrade 0.9.0 --> 2.3.3

Added by Andreas Schnederle-Wagner almost 9 years ago

Hello,

we are running Redmine 0.9.0 and want to upgrade to the latest Version (2.3.3)
Wanted to ask if this is possible or do we need to upgrade to 1.x.x before we got to 2.3.3? (is there an upgrade path we need to be aware of?)
Any known Problems?

Thank you
Andreas Schnederle-Wagner

Replies (2)

RE: Redmine upgrade 0.9.0 --> 2.3.3 - Added by Ivan Cenov almost 9 years ago

I used to upgrade every step up (for three years more than 20 upgrades) and always thought this is the right way to maintain Redmine. Many things changed along with Redmine: Ruby versions, rails versions, plugins versions.

From Redmine version 1.4.0, bundler is used to maintain Redmine.

Before Redmine 2.0, mongrel was used as http server; from Redmine 2.0 till now, thin or puma is used.

Before Redmine 2.0 ruby 1.8.7 + mysql; from Redmine 2.0 till now: ruby 1.9.3 + mysql2.

Changing mysql with mysql2 requires to change libmysql.dll (mySQL connector 6.0.2).

See what Redmine version what rails version uses.

Plugins: many of them have different versions for before 2.0 and after 2.0. Also some of them have changed to be compatible 2.2 and 2.3.

If I had to do this Redmine upgrade, I would choose incremental upgrade.

RE: Redmine upgrade 0.9.0 --> 2.3.3 - Added by Mischa The Evil almost 9 years ago

Some time ago I posted some pointers in RE: Upgrade help. Maybe it is useful for you...

(1-2/2)