[SOLVED] "Web application could not start" after 'upgrading' plugin

Added by Oscar Edvardsson almost 5 years ago

Hi,

Yesterday I tried to update the Scrum plugin we are using. Without thinking, I downloaded the archive, moved the old folder and unzipped the archive in its place. I then ran RAILS_ENV=production bundle exec rake redmine:plugins:migrate. I got some errors (don't remember which) and while mildly panicking, I tried replacing the folder with old one, trying to uninstall the plugin, etc.

So, now when I try to access Redmine I get the error message below. It is coincidentally the same as if I try to run the migrate-command, or try to remove the plugin.

Any suggestions to bring Redmine back to live is greatly appreciated!
Thanks in advance!

Child already added (RuntimeError)
/usr/share/redmine-3.2.0/lib/redmine/menu_manager.rb:339:in `add_at'
/usr/share/redmine-3.2.0/lib/redmine/menu_manager.rb:266:in `push'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:279:in `menu'
/usr/share/redmine-3.2.0/plugins/scrum.0.16.1/init.rb:78:in `block in <top (required)>'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:75:in `instance_eval'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:75:in `register'
/usr/share/redmine-3.2.0/plugins/scrum.0.16.1/init.rb:31:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `block in require'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:155:in `block in load'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:146:in `each'
/usr/share/redmine-3.2.0/lib/redmine/plugin.rb:146:in `load'
/usr/share/redmine-3.2.0/config/initializers/30-redmine.rb:21:in `<top (required)>'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `block in load'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/engine.rb:652:in `block in load_config_initializer'
/var/lib/gems/2.3.0/gems/activesupport-4.2.5/lib/active_support/notifications.rb:166:in `instrument'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/engine.rb:651:in `load_config_initializer'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/engine.rb:615:in `each'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/engine.rb:615:in `block in <class:Engine>'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:55:in `block in run_initializers'
/usr/lib/ruby/2.3.0/tsort.rb:228:in `block in tsort_each'
/usr/lib/ruby/2.3.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
/usr/lib/ruby/2.3.0/tsort.rb:422:in `block (2 levels) in each_strongly_connected_component_from'
/usr/lib/ruby/2.3.0/tsort.rb:431:in `each_strongly_connected_component_from'
/usr/lib/ruby/2.3.0/tsort.rb:421:in `block in each_strongly_connected_component_from'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:44:in `each'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:44:in `tsort_each_child'
/usr/lib/ruby/2.3.0/tsort.rb:415:in `call'
/usr/lib/ruby/2.3.0/tsort.rb:415:in `each_strongly_connected_component_from'
/usr/lib/ruby/2.3.0/tsort.rb:349:in `block in each_strongly_connected_component'
/usr/lib/ruby/2.3.0/tsort.rb:347:in `each'
/usr/lib/ruby/2.3.0/tsort.rb:347:in `call'
/usr/lib/ruby/2.3.0/tsort.rb:347:in `each_strongly_connected_component'
/usr/lib/ruby/2.3.0/tsort.rb:226:in `tsort_each'
/usr/lib/ruby/2.3.0/tsort.rb:205:in `tsort_each'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/2.3.0/gems/railties-4.2.5/lib/rails/application.rb:352:in `initialize!'
/usr/share/redmine-3.2.0/config/environment.rb:14:in `<top (required)>'
config.ru:3:in `require'
config.ru:3:in `block in <main>'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `instance_eval'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `initialize'
config.ru:1:in `new'
config.ru:1:in `<main>'
/var/lib/gems/2.3.0/gems/passenger-5.0.30/src/helper-scripts/rack-preloader.rb:110:in `eval'
/var/lib/gems/2.3.0/gems/passenger-5.0.30/src/helper-scripts/rack-preloader.rb:110:in `preload_app'
/var/lib/gems/2.3.0/gems/passenger-5.0.30/src/helper-scripts/rack-preloader.rb:156:in `<module:App>'
/var/lib/gems/2.3.0/gems/passenger-5.0.30/src/helper-scripts/rack-preloader.rb:30:in `<module:PhusionPassenger>'
/var/lib/gems/2.3.0/gems/passenger-5.0.30/src/helper-scripts/rack-preloader.rb:29:in `<main>'

Replies (7)

RE: "Web application could not start" after 'upgrading' plugin - Added by Leonel Iturralde almost 5 years ago

Hi,

I don't know if I get it right.
Did you uninstall the plugin? or you can't uninstall the plugin?

/usr/share/redmine-3.2.0/plugins/scrum.0.16.1/init.rb:78:in `block in <top (required)>'

Because the line above indicate some sort of problem with the scrum plugin.

Try removing the folder. And running redmine without it.

RE: "Web application could not start" after 'upgrading' plugin - Added by Oscar Edvardsson almost 5 years ago

Thanks for the reply. :)

I can't uninstall it. If I run sudo bundle exec rake redmine:plugins:migrate NAME=scrum VERSION=0 RAILS_ENV=production, the console spits out the same error as the web page. There is no change if I remove (rename) the folder.

RE: "Web application could not start" after 'upgrading' plugin - Added by Leonel Iturralde almost 5 years ago

My suggestion is to try running redmine without the plugin.
Just make redmine go live again.

RE: "Web application could not start" after 'upgrading' plugin - Added by Oscar Edvardsson almost 5 years ago

How would I do that? I can not access the web interface (obviously), removing the plugin folder doesn't change anything and I can't uninstall it the normal way. :/

RE: "Web application could not start" after 'upgrading' plugin - Added by Leonel Iturralde almost 5 years ago

Oscar Edvardsson wrote:

How would I do that? I can not access the web interface (obviously), removing the plugin folder doesn't change anything and I can't uninstall it the normal way. :/

After removing the scrum plugin folder throws the same error as before.

RE: "Web application could not start" after 'upgrading' plugin - Added by Oscar Edvardsson almost 5 years ago

Yes, same error after removing the scrum folder from plugins folder.

RE: "Web application could not start" after 'upgrading' plugin - Added by Oscar Edvardsson almost 5 years ago

Ah, my bad. I thought renaming was equivalent to removing. Apparently, it isn't, so when I had two folders (scrum.0.16.1 and scrum.0.16.0) I got the above error. I removed one of the folders, renamed the remaining and could then do the migrate!

(1-7/7)