SMTP setting not working

Added by Martin Neuß 5 days ago

Hi

as i ´ve already written i ´m new to redmine. i ´ve installed it on my synology ds920+ using the provided redmine package.
to be able to send email i ´ve set the environment variables to (see screenshot) so i thought it should work. trying to send a test mail i got the message: temporary failure in name resolution.
searching the net was inconclusive as some found no real reason, some answered commonplace as „check your settings“ or „dns not working“ or such.
but one mentioned that the dns server has to be configured in etc/resolv.conf. which doesn ´t exist in the synology´s docker container.

Is anybody able to help?
Have i made an error in the config settings which i simply overlooked,

Thanks for the answers

Martin

Replies (5)

RE: SMTP setting not working - Added by C S 5 days ago

Try without SMTP_DOMAIN

RE: SMTP setting not working - Added by Martin Neuß 5 days ago

Hi,

thanks for your fast response.

i tried with direct ip-adresses (out of whois) - name resolution no problem but:
- with the ip address for strato.de (connection refused: no port 587 available)
- with the ip address for an smtp-server (out of the SPF-records): Beim Senden einer E-Mail ist ein Fehler aufgetreten (hostname "81.169.145.133" does not match the server certificate).

so i think i ´m stuck with: a) inserting the url smtp.strato.de for the smtp-server and configuring a nameserver for the container (mainly due to the last error)

of course i ´ll try your suggestion but i think it will be of no help.

i ´ll create a resolv.conf file in a new folder etc and enter a nameserver entry such as nameserver 8.8.8.8 for google or so.

does this t seem to be sound to you?

with best regards

MArtin

RE: SMTP setting not working - Added by Martin Neuß 5 days ago

I tried your suggestion, temproary failure of name resolution returns.
so i think it´s the missing nameserver entry.

MArtin

RE: SMTP setting not working - Added by C S 5 days ago

I think strato doesn't support Port 587 TLS so you have to use ssl Port 465?

RE: SMTP setting not working - Added by Martin Neuß 5 days ago

my normal email setup is going via 587.

both ports are possible (as mentioned by strato on their configuration pages).
i think that the first ip was just the domain main servers ip which was returned by whois. the smtp servers seem to have another ip (as shown by startos spf record). there port 587 was available but the ssl credentials - to my understanding - expected to see the domain name „smtp.strato.de“ instead of its ip address.

i ´ll report back when i ´ve tried it.

martin

(1-5/5)