Defect #10915

Issue CSV export does not respect the "page=" request

Added by Cheyenne Wills about 8 years ago. Updated about 7 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution: Affected version:1.4.2

Description

I was able to duplicate this using the redmine.org site..

  • click on the "Also available in" CSV link
    • A pop-up appears, just select the export button. A csv file is downloaded.
  • click on the "Next" link to go to the next page
  • click on the "Also available in" CSV link
    • A pop-up appears, just select the export button. Another csv fle is downloaded.

The contents of the two files are the same.

I was expecting the 2nd csv file to contain the contents of the 2nd page.

It appears that if you bypass the pop-up (javascript) by right clicking on the CSV link, the data is downloaded correctly.

My web client is "Chromium Version 19.0.1084.36 (0)" running on a Gentoo system.


Related issues

Related to Redmine - Feature #13770: Show warning, when exported issues exceed the limit Closed

History

#1 Updated by Filou Centrinov about 7 years ago

You are right, but this is not a bug. The CSV link tries always to export all issues that where filted (not the issues that are shown), but the export is limited by a maximal allowed issues. You can define the limit in admin settings.

I created a new issue #13770

Close this issue?

#2 Updated by Cheyenne Wills about 7 years ago

  • Status changed from New to Resolved

I determined that the limit was due to the setting... so it is "working as designed". Feel free to close the issue. I addressed the problem with the users by providing them with a small program that runs their query via the REST API.

The new issue you opened will address letting the users know what is happening.

#3 Updated by Daniel Felix about 7 years ago

  • Status changed from Resolved to Closed

Thanks for the feedback. I'm closing this issue.

Also available in: Atom PDF