Feature #15225

Need to be able to have separate markup formats for bugs and wiki pages

Added by Peter Zion over 8 years ago. Updated about 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Duplicate

Description

On our setup we are finding it problematic to have bugs formatted in textile (or any other markup text format) since people don't really pay attention to formatting when entering bugs.

On the other hand, we heavily use markup for wiki pages (of course).

What we would like is to be able to separately select the markup format for bug reports and for wiki pages. In our case, for wiki pages it would be "reStructuredTex" (using a plugin) and for bugs it would be "none".

It would be awesome to be able to override the format on any bug text or wiki page, but in generally what I suggested above will fix the issue in 99% of the cases.

Apologies if this is a duplicate; I did a search but nothing appeared to be a good match.


Related issues

Duplicates Redmine - Feature #5112: Texting formatting setting is global (Allow override in m... New 2010-03-18

History

#1 Updated by Jan Niggemann (redmine.org team member) over 8 years ago

In our case, for wiki pages it would be "reStructuredTex" (using a plugin) and for bugs it would be "none".

IHMO this use case only affects very few users.

and for bugs it would be "none".

Err, why don't your users just stop using formatting?

#2 Updated by Peter Zion over 8 years ago

Stopping formatting would mean never pasting source code into a bug report, or always remembering to encapsulate it with

...

I believe that fact that we are using reStructuredText is irrelevant since we had the same problem when using textile as the format.

#3 Updated by Peter Zion over 8 years ago

That is a good example right there :-)

#4 Updated by Go MAEDA about 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I am closing this issue as a duplicate of #5112.

#5 Updated by Go MAEDA about 7 years ago

  • Duplicates Feature #5112: Texting formatting setting is global (Allow override in module level) added

Also available in: Atom PDF