Project

General

Profile

Actions

Defect #15622

closed

Unable to add watcher who is not a member of the project

Added by Daniel Hochman over 9 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

The feature described in #5159 (Ability to add Non-Member watchers to the watch list) is confirmed as not working in Redmine 2.3.1 and 2.3.3

You can only add people who are members of the given project.

Actions #1

Updated by Toshi MARUYAMA over 9 years ago

  • Status changed from New to Needs feedback
  • Resolution set to Cant reproduce

I added some tests and tests pass.
I cannot reproduce on r12396.

Actions #2

Updated by Daniel Hochman over 9 years ago

My guess is the bug only happens with specific project or perhaps role settings.
Our projects are public and the members all have the same role. There is a role in our Redmine called Non Member and almost all permissions are checked for that role. I don't see an option for the non-member role of "Add as Watcher" I do see "Add watchers" which is checked.

If the non-member opens the issues themselves they can click on the "Watch" link with no issue. However, the auto-complete add watcher function does not display non-member.

We are also using "Watchers Textinput plugin" but I recall disabling that and I also had the issue.

Other people have reported this issue as well so we are not alone... (see #5159)

Actions #3

Updated by Toshi MARUYAMA over 9 years ago

I cannot see any problems in this method.
source:tags/2.4.1/app/controllers/watchers_controller.rb#L68

Actions #4

Updated by Go MAEDA over 4 years ago

  • Status changed from Needs feedback to Closed

Please open a new issue if you still experience this problem with the latest version of Redmine.

Actions

Also available in: Atom PDF