Defect #15987

Wrong search pagination

Added by Daniel Felix over 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Search engine
Target version:-
Resolution:Duplicate Affected version:

Description

Hi team,

I've encountered some strange search result behaviour.

We're using SQL Server for our instance with the latest Ruby Release (2.1.0) But we've encountered the same behaviour earlier with the older Redmine Releases (2.2 to 2.5-devel).

For example:
Search as admin for "test". We're getting nearly 650 results. If I try to paginate next, everything seems to be ok, but in fact I'm not on page 2, instead I'm on the penultimate page (Pagecount -1). If I press next again, I'm on the last page of my 650 results.

This seems to be a bug. I can replicate it everytime. Even on fresh installs.

The next URL seems to give the resolution:
I searched today for "test", the next link has a strange offset:
/search?offset= 20130603084359 &q=test&utf8=%E2%9C%93


Related issues

Duplicates Redmine - Defect #16239: Search does not return all the results Closed

History

#1 Updated by Darth Vader over 7 years ago

I believe this is a duplicate of #16239. See our resolution.

#2 Updated by Toshi MARUYAMA about 7 years ago

  • Category set to Search engine

#3 Updated by Toshi MARUYAMA about 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Darth Vader wrote:

I believe this is a duplicate of #16239. See our resolution.

Thank you for your pointing.
I close this issue because #16239 has descriptions and notes more details.

#4 Updated by Toshi MARUYAMA about 7 years ago

  • Duplicates Defect #16239: Search does not return all the results added

Also available in: Atom PDF