Project

General

Profile

Actions

Feature #19171

closed

"any open / none open" filter for ( follows / blocked ) relationships

Added by Adrian Wilkins about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Currently you can filter issues with related issues.

is
any issues in project
any issues not in project
no issues in project
none
all

Propose that adding

any open
none open

Would improve the software

  • You could then construct issue queries that only return issues that can actually be progressed
    • This reduces your cognitive load having to think about whether a given task can be done or not
  • Can also construct queries that return issues that are blocked by something
    • This allows you to troubleshoot their dependencies

Related issues

Is duplicate of Redmine - Feature #15029: When filter by "blocked by" = "any", take into account if blocking issue is already closed (so no really blocking)Closed

Actions
Actions #1

Updated by Matteo Bonaker over 8 years ago

Is this possibily another duplicate of #3265 or #15029?

Actions #2

Updated by Adrian Wilkins over 8 years ago

Agree that this is a dupe of #15029, but not #3265

#3265 was the creation of the relationship-filtering feature, this ticket and #15029 refer to improving that filter so that you can use it to find issues with and without active blockers.

There's also a patch #16621 which seems to implement this ; I couldn't get this to apply against 3.0.3 - I've asked the original author which revision he patched in #16621#note-2

Actions #3

Updated by Mischa The Evil over 8 years ago

  • Is duplicate of Feature #15029: When filter by "blocked by" = "any", take into account if blocking issue is already closed (so no really blocking) added
Actions #4

Updated by Mischa The Evil over 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Adrian Wilkins wrote:

Agree that this is a dupe of #15029 [...]

So I'm closing this one accordingly.

Adrian Wilkins wrote:

#3265 was the creation of the relationship-filtering feature, this ticket and #15029 refer to improving that filter [...]

Indeed.

Thanks for the feedback. Mischa.

Actions

Also available in: Atom PDF