Defect #20034

Custom queries cannot be edit after creation

Added by Daniele Renda over 6 years ago. Updated almost 5 years ago.

Status:Needs feedbackStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution: Affected version:3.0.3

Description

I created a custom query in a project with a role that permit of course custom queries. In the query I checked the "for all projects" checkbox.

After the creation, I'm not able anymore to edit the query; every time I try to change it I've a 403 forbidden error.

I think this is a regression, in fact with old 2.5.1 redmine version all worked fine.

History

#1 Updated by Daniele Renda over 6 years ago

Hi,
someone took a look to this bug?

Thanks

#2 Updated by Robert Schneider over 6 years ago

I tried it on my redmine but could not reproduce it. Maybe the user has different permissions in the projects? You could mention that if it is the case...

#3 Updated by Daniele Renda over 6 years ago

I'm the manager of the project, so I've the high level permissions on it. Please note that the problem is visible on version 3.0.3 od redmine

#4 Updated by Toshi MARUYAMA over 6 years ago

  • Status changed from New to Needs feedback

#5 Updated by Yuri Weinstein over 5 years ago

We observed the same problem in version 3.1.1.stable
Can someone update on progress of this issue?

#6 Updated by Toshi MARUYAMA over 5 years ago

Submissions:

Before submitting a bug report here, please make sure:
...

#7 Updated by Luca Lesinigo almost 5 years ago

For what it's worth, our setup was born as v3.3.0 and we were able to edit and delete custom queries for all projects.
We recently upgraded to v3.3.2 and still no problems with custom queries.

Also available in: Atom PDF