Feature #20404

REST API support for project files (attachments)

Added by Heiko Robert almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

The files tab is a nice mechanism to provide any compiled artefacts by version. Unfortunately there is no REST-API support for at least downloadig (uploading would be perfect). e.g.

file list in that project from version_Id=3

GET /projects/redmine/files?version_id=3

get file with id
GET /projects/redmine/files/123

get file with name
GET /projects/redmine/files/redmine.jar

get file with name from version
GET /projects/redmine/files/redmine.jar?version_id=3


Related issues

Duplicates Redmine - Feature #7725: REST API for files Closed 2011-02-25

History

#1 Updated by Heiko Robert almost 6 years ago

Maybe easier to implement to reuse the logic from the page:

GET /projects/redmine/files.xml

GET /projects/redmine/files.xml?version_id=123

#2 Updated by Mischa The Evil almost 6 years ago

#3 Updated by Mischa The Evil almost 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #7725. See also its related issues #13800 and #19116.

Also available in: Atom PDF