Defect #21011

Watchers can not be deleted from a ticket

Added by Thorsten H. almost 7 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:3.1.1

Description

Watchers can not be deleted from a ticket if Redmine 3.1.1 on Apache (mod_fcgi)/Passenger runs;
Over /usr/bin/ruby bin/rails server webrick -e production watchers can be delete from a ticket


Related issues

Related to Redmine - Defect #14325: not possible to manage watchers after upgrade to 2.3.1 Closed

History

#1 Updated by Thorsten H. almost 7 years ago

Environment:
Redmine version 3.1.1.stable.14669
Ruby version 2.0.0-p598 (2014-11-13) [x86_64-linux]
Rails version 4.2.4
Environment production
Database adapter Mysql2
SCM:
Subversion 1.7.14
Git 1.8.3.1
Filesystem
Redmine plugins:
no plugin installed

#2 Updated by Go MAEDA almost 7 years ago

What web browser do you use? Can you add watchers? Do you see any error messages?

#3 Updated by Thorsten H. almost 7 years ago

Test with Microsoft Edge, Internet Explorer 11 and Firefox 41.0.1 - no error message

#4 Updated by Thorsten H. almost 7 years ago

i can add new observers - but not delete - i am administrator/manager...

#5 Updated by Thorsten H. almost 7 years ago

Apache logfile:

84.181.XXX.XXX - - [17/Oct/2015:01:27:47 +0200] "DELETE /issues/2/watchers/5 HTTP/1.1" 403 221 "https://redmine.domain.tld/issues/2" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; MAAU; rv:11.0) like Gecko"

#6 Updated by Go MAEDA almost 6 years ago

  • Subject changed from Observers can not be deleted from a ticket to Watchers can not be deleted from a ticket
  • Description updated (diff)
  • Category set to Issues
  • Status changed from New to Closed
  • Resolution set to Invalid

#7 Updated by Go MAEDA over 5 years ago

  • Related to Defect #14325: not possible to manage watchers after upgrade to 2.3.1 added

Also available in: Atom PDF