Project

General

Profile

Actions

Patch #26503

closed

Update nokogiri gem (~> 1.8.0)

Added by Go MAEDA over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Gems support
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Now we can update Nokogiri to 1.8.0 because Ruby 2.1 support has been dropped by #25538 and #23630.

Quotation from CHANGELOG of Nokogiri 1.8.0 :

This release ends support for Ruby 2.1 on Windows in the x86-mingw32 and x64-mingw32 platform gems (containing pre-compiled DLLs). Official support ended for Ruby 2.1 on 2017-04-01.

Index: Gemfile
===================================================================
--- Gemfile    (revision 16868)
+++ Gemfile    (working copy)
@@ -13,7 +13,7 @@
 gem "roadie", "~> 3.2.1" 
 gem "mimemagic" 

-gem "nokogiri", "~> 1.7.2" 
+gem "nokogiri", "~> 1.8.0" 
 gem "i18n", "~> 0.7.0" 

 # Request at least rails-html-sanitizer 1.0.3 because of security advisories

Related issues

Related to Redmine - Defect #27505: Cannot install nokogiri 1.7 on Windows Ruby 2.4Closed

Actions
Blocked by Redmine - Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now requiredClosedJean-Philippe Lang

Actions
Actions #1

Updated by Jean-Philippe Lang over 6 years ago

  • Target version set to 4.0.0
Actions #2

Updated by Go MAEDA over 6 years ago

  • Blocked by Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now required added
Actions #3

Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang

Committed, thanks.

Actions #4

Updated by Toshi MARUYAMA about 6 years ago

  • Related to Defect #27505: Cannot install nokogiri 1.7 on Windows Ruby 2.4 added
Actions

Also available in: Atom PDF