Cannot install nokogiri 1.7 on Windows Ruby 2.4
I can`t install Redmine 3.4.3 with Ruby 2.4, because it needs nokogiri 1.7.2
nokogiri 1.7.2 has limitation:
REQUIRED RUBY VERSION:
< 2.4, >= 2.1.0
We can use nokogiri >= 1.8.0 in Gemfile for Ruby 2.4
#1 Updated by Toshi MARUYAMA over 3 years ago
- Status changed from New to Needs feedback
I cannot reproduce on my CentOS 7.
Do you use Windows?
It seems Nokogori switches requiring Ruby version by OS.
#3 Updated by Ivan Cenov over 3 years ago
I cannot install Redmine 3.4.3 in following configuration
E:\data\redmine>ruby -v ruby 2.4.2p198 (2017-09-14 revision 59899) [i386-mingw32] E:\data\redmine>cmd /version Microsoft Windows [Version 10.0.14393] (c) 2016 Microsoft Corporation. All rights reserved.Ruby is installed from https://github.com/oneclick/rubyinstaller2/releases/download/rubyinstaller-2.4.2-2/rubyinstaller-2.4.2-2-x86.exe (the link from https://rubyinstaller.org/downloads/).
gem "nokogiri", (RUBY_VERSION >= "2.1" ? "~> 1.7.2" : "~> 1.6.8")
E:\data\redmine>bundle install --without development test rmagick Ignoring thin-1.7.2 because its extensions are not built. Try: gem pristine thin --version 1.7.2 Ignoring thin-1.7.2 because its extensions are not built. Try: gem pristine thin --version 1.7.2 Fetching gem metadata from https://rubygems.org/.......... Fetching gem metadata from https://rubygems.org/. Resolving dependencies... Bundler could not find compatible versions for gem "ruby ": In Gemfile: ruby x86-mingw32 nokogiri (~> 1.7.2) x86-mingw32 was resolved to 1.7.2, which depends on ruby (< 2.4) x86-mingw32
#6 Updated by Toshi MARUYAMA over 3 years ago
I have sent pull request.