Project

General

Profile

Actions

Defect #30809

closed

Spent time report > CSV not obeying filters

Added by Maxim Krušina about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
Time tracking
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

When exporting time sheet from Project / Spent time / Report, the exported CSV contains much more information than visible on screen - in my case, it contains all versions from all projects, not only from the current one.


Related issues

Is duplicate of Redmine - Defect #31511: CSV export of time entries report does not honor project filterClosedGo MAEDA

Actions
Actions #1

Updated by Go MAEDA almost 5 years ago

  • Status changed from New to Needs feedback

I cannot reproduce the problem. Could you show the detailed steps to reproduce?

Actions #2

Updated by Vilppu Vuorinen over 4 years ago

Go MAEDA wrote:

I cannot reproduce the problem. Could you show the detailed steps to reproduce?

I can reproduce this on 4.0.2. It looks like this is regression related to #13618.

Steps

  1. Navigate to a project
  2. Navigate to Spent time of the project
  3. Select Report, Details: Month, Add: Project
  4. Download as CSV

Expected result

CSV file containing spent time entries of the current project

Actual result

CSV file containing monthly spent time of every project

Actions #3

Updated by Mizuki ISHIKAWA over 4 years ago

I think this problem is related to #31511.
#31511 was fixed in Redmine 4.0.4.

Actions #4

Updated by Go MAEDA over 4 years ago

  • Is duplicate of Defect #31511: CSV export of time entries report does not honor project filter added
Actions #5

Updated by Go MAEDA over 4 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Mizuki ISHIKAWA wrote:

I think this problem is related to #31511.
#31511 was fixed in Redmine 4.0.4.

Exactly. Thank you for pointing it out.

Actions

Also available in: Atom PDF