Defect #32198

Issues associated revisions not showing due to bad reference to lvar instead of ivar

Added by José Esteves almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:

Description

Fixes bad references on issue_controller

This is the error

NameError in IssuesController#issue_tab

undefined local variable or method `changesets' for #<IssuesController:0x0000556756ef61f0>
Did you mean?  @changesets
Extracted source (around line #207):

#205     when 'changesets'
#206       @changesets = @issue.changesets.visible.preload(:repository, :user).to_a
*207       changesets.reverse! if User.current.wants_comments_in_reverse_order?
#208       render :partial => 'issues/tabs/changesets', :locals => {:changesets => @changesets}
#209     end
#210   end

Extracted source (around line #6):

#4   module BasicImplicitRender # :nodoc:
#5     def send_action(method, *args)
*6       super.tap { default_render unless performed? }
#7     end
#8 
#9     def default_render(*args)

Extracted source (around line #194):

#192       # which is *not* necessarily the same as the action name.
#193       def process_action(method_name, *args)
*194         send_action(method_name, *args)
#195       end
#196 
#197       # Actually call the method associated with the action. Override

issues_controller-fix-reference.diff Magnifier (1.09 KB) José Esteves, 2019-10-04 21:21

IMG1.png (45.9 KB) José Esteves, 2019-10-04 21:25


Related issues

Related to Redmine - Feature #3058: Show issue history using tabs Closed 2009-03-26

Associated revisions

Revision 18598
Added by Go MAEDA almost 2 years ago

Fix that "Associated revisions" tab has no content when the user displays comments in reverse chronological order (#32198, #3058).

Patch by José Esteves.

History

#1 Updated by Mischa The Evil almost 2 years ago

#2 Updated by Mischa The Evil almost 2 years ago

  • Subject changed from Issues associated revisión not showing due to bad reference to Issues associated revisions not showing due to bad reference to lvar instead of ivar

#3 Updated by Go MAEDA almost 2 years ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Confirmed
  • Target version set to 4.1.0

#4 Updated by Go MAEDA almost 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA
  • Target version deleted (4.1.0)
  • Resolution set to Fixed

Committed the patch as a part of #3058. Thank you for detecting and reporting this issue.

#5 Updated by José Esteves almost 2 years ago

Go MAEDA wrote:

Committed the patch as a part of #3058. Thank you for detecting and reporting this issue.

Glad to help! :)

#6 Updated by Go MAEDA almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF