Patch #32841

Drop support for Bundler prior to 1.12.0

Added by Go MAEDA 6 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gems support
Target version:4.2.0

Description

r19425 added "ruby" directive in Gemfile in order to reject Ruby 2.7, but the directive causes parse error if the version of bundler is earlier than 1.12.0 (released in April 2016).

$ bundle update

[!] There was an error parsing `Gemfile`: no implicit conversion of Symbol into Integer. Bundler cannot continue.

 #  from /Users/maeda/redmines/trunk/Gemfile:3
 #  -------------------------------------------
 #
 >  ruby '>= 2.3.0', '< 2.7.0'
 #  gem "bundler", ">= 1.5.0" 
 #  -------------------------------------------

The attached patch changes the minimum required version of bundler described in Gemfile and doc/INSTALL.

require-bundler-1_12-or-later.diff Magnifier (649 Bytes) Go MAEDA, 2020-01-20 06:16

drop-support-for-bundler-prior-to-1_12.patch Magnifier (652 Bytes) Go MAEDA, 2020-01-26 02:35


Related issues

Related to Redmine - Patch #32788: Specify supported Ruby version in Gemfile and doc/INSTALL Closed
Blocked by Redmine - Defect #32839: Redmine 4.1 installation fails due to an attempt to insta... Closed

Associated revisions

Revision 19468
Added by Go MAEDA 5 months ago

Drop support for Bundler prior to 1.12.0 (#32841).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA 6 months ago

  • Target version set to 4.0.7

Setting the target version to 4.0.7.

#2 Updated by Go MAEDA 6 months ago

  • Blocked by Defect #32839: Redmine 4.1 installation fails due to an attempt to install sprockets 4.0.0 if bundler prior to 1.15.2 is used on Ruby prior to 2.5 added

#3 Updated by Go MAEDA 6 months ago

  • Related to Patch #32788: Specify supported Ruby version in Gemfile and doc/INSTALL added

#4 Updated by Go MAEDA 6 months ago

  • Target version deleted (4.0.7)

I think #32788#note-7 is a better solution because it does not force admins to update bundler.

Removing the target version.

#5 Updated by Go MAEDA 6 months ago

Go MAEDA wrote:

I think #32788#note-7 is a better solution because it does not force admins to update bundler.

The change has been committed as r19463 but "if Bundler::VERSION >= '1.12.0'" does not look good. So, I suggest dropping the support for the Bundler before 1.12.0 in Redmine 4.2.0.

Although raising the minimum required version of Bundler in minor releases may inconvenience some users, raising in major releases is not a matter because users expect that major releases have many big changes.

The attached patch changes Gemfile to require Bundler 1.12.0 or later.

#6 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch.

Also available in: Atom PDF