Patch #35500

Add missing fixture to IssuesTest

Added by Yuichi HARADA 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:-

Description

IssuesTest has failed.

% RAILS_ENV=test bundle exec rake db:migrate:reset

% RAILS_ENV=test bundle exec rake test TEST=test/integration/issues_test.rb
Run options: --seed 64650

# Running:

.F

Failure:
IssuesTest#test_invalid_operators_should_render_404 [test/integration/issues_test.rb:334]:
Expected response to be a <404: Not Found>, but was a <200: OK>.
Expected: 404
  Actual: 200

rails test test/integration/issues_test.rb:326

.................

Finished in 3.792454s, 5.0099 runs/s, 21.3582 assertions/s.
19 runs, 81 assertions, 1 failures, 0 errors, 0 skips

The cause was an insufficient fixture.

diff --git a/test/integration/issues_test.rb b/test/integration/issues_test.rb
index 21b20759a0..9193e00889 100644
--- a/test/integration/issues_test.rb
+++ b/test/integration/issues_test.rb
@@ -33,7 +33,7 @@ class IssuesTest < Redmine::IntegrationTest
            :enumerations,
            :custom_fields,
            :custom_values,
-           :custom_fields_trackers,
+           :custom_fields_trackers, :custom_fields_projects,
            :attachments

   # create an issue

Related issues

Related to Redmine - Patch #35312: Gracefully handle invalid operators and associations requ... Closed

Associated revisions

Revision 21055
Added by Go MAEDA 3 months ago

Add missing fixture to IssuesTest (#35312, #35500).

Patch by Yuichi HARADA.

History

#1 Updated by Go MAEDA 3 months ago

  • Related to Patch #35312: Gracefully handle invalid operators and associations requested in queries added

#2 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch as a part of #35312. Thank you.

Also available in: Atom PDF