Feature #35562

Show warning in admin/info when there are pending migrations

Added by Go MAEDA 4 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Administration
Target version:5.0.0
Resolution:Fixed

Description

The attached patch adds an indication to the admin/info page whether all database migrations have been run or not.

Some users forget to run the rake task db:migrate when they update Redmine and encounter errors. Sometimes it is difficult for users new to Ruby on Rails to identify that the cause is that database migrations have not been run (examples: NoMethodError undefined method set_inheritance_column for..., RE: Can't access my project on Redmine 4.1.1).

The new indication that the patch introduces gives such users a chance to know the cause. It is also useful for people who are asked help from such users to figure out the cause.

pending-migrations-indicator.png (100 KB) Go MAEDA, 2021-07-14 09:34

check_pending_migrations.patch Magnifier (1.53 KB) Go MAEDA, 2021-07-14 09:46

Associated revisions

Revision 21110
Added by Go MAEDA 3 months ago

Show warning in admin/info when there are pending migrations (#35562).

Patch by Go MAEDA.

Revision 21111
Added by Go MAEDA 3 months ago

Update locales (#35562).

History

#1 Updated by Go MAEDA 3 months ago

  • Target version set to Candidate for next major release

#2 Updated by Go MAEDA 3 months ago

  • Target version changed from Candidate for next major release to 5.0.0

Setting the target version to 5.0.0.

#3 Updated by Marius BALTEANU 3 months ago

Nice improvement!

#4 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch.

Also available in: Atom PDF