Defect #37718

Repository browser does not show "+" (plus sign) in filename

Added by Go MAEDA 2 months ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Marius BALTEANU% Done:

0%

Category:SCM
Target version:4.2.8
Resolution:Fixed Affected version:4.2.0

Description

As reported in the forum post Cannot browse file contents that filename contains "+" i..., plus sings in filenames are not displayed in the repository browser when browsing a Subversion repository.


Related issues

Related to Redmine - Defect #32752: Ruby 2.7: Remove deprecated URI.escape/unescape Closed

Associated revisions

Revision 21880
Added by Marius BALTEANU about 1 month ago

Fix repository browser does not show \"+\" (plus sign) in filename (#37718).

Patch by Go MAEDA.

Revision 21881
Added by Marius BALTEANU about 1 month ago

Merge r21880 from trunk to 5.0-stable (#37718).

Revision 21882
Added by Marius BALTEANU about 1 month ago

Backport only the fix without tests to 4.2-stable (#37718).

History

#1 Updated by Go MAEDA 2 months ago

This issue is appeared to be caused by r19455 that replaced URI.escape with CGI.escape at source:trunk/lib/redmine/scm/adapters/subversion_adapter.rb@19455#L111.

$ irb
irb(main):001:0> RUBY_VERSION
=> "2.6.9" 
irb(main):002:0> require 'cgi'
=> true
irb(main):003:0> CGI.unescape('+.txt')
=> " .txt" 
irb(main):004:0> URI.unescape('+.txt')
=> "+.txt" 

#2 Updated by Go MAEDA 2 months ago

  • Related to Defect #32752: Ruby 2.7: Remove deprecated URI.escape/unescape added

#3 Updated by Go MAEDA 2 months ago

  • Affected version set to 4.2.0

#4 Updated by Go MAEDA 2 months ago

Attaching a patch to fix the issue.

#5 Updated by Go MAEDA 2 months ago

  • Target version set to Candidate for next minor release

#6 Updated by Go MAEDA 2 months ago

  • Subject changed from Repository browser does not show plus sign in filename to Repository browser does not show "+" (plus sign) in filename

#7 Updated by Go MAEDA about 1 month ago

  • Target version changed from Candidate for next minor release to 4.2.9

Setting the target version to 4.2.9.

#8 Updated by Marius BALTEANU about 1 month ago

  • Assignee set to Marius BALTEANU
  • Target version changed from 4.2.9 to 4.2.8

#9 Updated by Marius BALTEANU about 1 month ago

  • Status changed from New to Resolved
  • Resolution set to Fixed

I've committed and merged the fix to 5.0-stable and 4.2-stable branches with one mention: for 4.2-stable, I've backport only the fix because the changes to the tests do not apply cleanly (caused by #16849).

#10 Updated by Marius BALTEANU about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF