Patch #38122

Remove Bundler from requirements

Added by Go MAEDA about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:


Category:Gems support
Target version:5.1.0


In Ruby 2.6 and later, Bundler is installed by default. Redmine does not support Ruby versions earlier than 2.5, which means that all supported versions of Ruby already include Bundler. Therefore, there is no need to install Bundler explicitly.

As a result, we can remove any references to Bundler in the following files:

  • doc/INSTALL: remove Bundler from the "Requirements" section
  • Gemfile: remove the line gem 'bundler', '>= 1.12.0'. The version of Bundler included with Ruby 2.6.0 (1.17.2) is more recent and there is no chance that an older version such as 1.11 will be used during the installation of Redmine

remove-bundler-from-requirements.diff Magnifier (580 Bytes) Go MAEDA, 2022-12-27 05:38

Related issues

Related to Redmine - Feature #30118: Ruby 2.6 support Closed
Related to Redmine - Patch #37159: Drop Ruby 2.5 support Closed

Associated revisions

Revision 22005
Added by Go MAEDA about 1 month ago

Remove Bundler from Requirements (#38122).

Patch by Go MAEDA.


#1 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Target version set to 5.1.0

Committed the patch.

#2 Updated by Go MAEDA about 1 month ago

#3 Updated by Go MAEDA about 1 month ago

Also available in: Atom PDF