Patch #38135

Allow use of Puma 6.0.0 or later

Added by Go MAEDA about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gems support
Target version:5.0.5

Description

Since Capybara 3.37 and earlier did not support Puma 6, we have updated the Gemfile in r21934 to use Puma < 6.0.0.

Capybara 3.38.0 was released in November 2022 and it is compatible with Puma 6, so we can remove that limitation.

38135.patch Magnifier (664 Bytes) Go MAEDA, 2022-12-28 08:27


Related issues

Related to Redmine - Patch #37867: Limit puma < 6.0.0 to avoid system test error Closed

Associated revisions

Revision 22011
Added by Go MAEDA about 1 month ago

Allow use of Puma 6.0.0 or later (#38135).

Capybara >= 3.39.0 supports Puma 6.0.

Revision 22017
Added by Go MAEDA about 1 month ago

Merged r22011 from trunk to 5.0-stable (#38135).

History

#1 Updated by Go MAEDA about 1 month ago

#2 Updated by Go MAEDA about 1 month ago

  • Related to Patch #37867: Limit puma < 6.0.0 to avoid system test error added

#3 Updated by Go MAEDA about 1 month ago

  • Target version set to 5.0.5

#4 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Resolved
  • Assignee set to Go MAEDA

Committed the patch.

#5 Updated by Go MAEDA about 1 month ago

  • Target version changed from 5.0.5 to 4.2.10

#6 Updated by Go MAEDA about 1 month ago

  • Target version changed from 4.2.10 to 5.0.5

#7 Updated by Go MAEDA about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF