Project

General

Profile

Actions

Feature #5653

open

My page - blocks

Added by Petr Pospisil over 13 years ago. Updated almost 11 years ago.

Status:
Reopened
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
2010-06-08
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

Hi guys,

Why my page uses <%= render :partial => "my/blocks/#{b}", :locals => { :user => user user } %> and every my/block/.. ignores the user variable? Why is passed? If I want to see my page of another user I have to rewrite all my blocks to use passed "user" variable and not "Issue.visible, user user, etc.". Thanks in advance. Petr


Files

_timelog.rhtml (2.27 KB) _timelog.rhtml Petr Pospisil, 2010-06-08 12:19
Actions #1

Updated by Petr Pospisil over 13 years ago

There is a example of one block - timelog. The modification is easy - just delete "@" before "user". Do it at all :o).

Actions #2

Updated by Petr Pospisil over 13 years ago

trunk is affected too.

Actions #3

Updated by Felix Schäfer over 13 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

As the name says: it's My Page, where you can see information pertaining to _your_self, if you want to see other things, use user-defined queries.

Actions #4

Updated by Petr Pospisil over 13 years ago

  • Status changed from Closed to Reopened

so it is feature :(. So why user user is passed? Because it is my page?

"if you want to see other things, use user-defined queries." What? I am in admin role. I am using LDAP auth. How I can see what the user has on the my page?

Actions #5

Updated by Petr Pospisil over 13 years ago

If it were written the way it was meant, so there would not be a problem to write my own plugin to switch "current identity" for my page. You said - yes we are sending a user variable to block, but we don't use it. And of course, it is not a bug, it is a feature. It is a Microsoft way.

Actions #6

Updated by Daniel Felix almost 11 years ago

  • Tracker changed from Defect to Feature
  • Resolution deleted (Invalid)
Actions

Also available in: Atom PDF