Defect #6802

Autolinking should not occur in link titles

Added by Alejandro Mery over 11 years ago. Updated almost 4 years ago.

Status:NewStart date:2010-11-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution: Affected version:

Description

In [[www|www.example.org]] the title incorrectly gets converted into an external link.

Using 1.0-stable branch.

History

#1 Updated by Holger Just over 11 years ago

  • Subject changed from autolinking should not occur for titles to Autolinking should not occur in link titles
  • Category set to Text formatting
  • Affected version (unused) set to devel

The issue is actually the other way round. The auto linking of URLs (performed by inline_auto_link in textile/formatter occurs occurs first, the wiki link is only generated after than.

Thus, the above statement is transformed into:

Current behavior
  1. [[www|www.example.org]]
  2. [[www|<a class="external" href="http://www.example.org">www.example.org</a>]]
  3. <a href="/projects/redmine/wiki/www" class="wiki-page new"><a class="external" href="http://www.example.org">www.example.org</a></a>
Expected
  1. [[www|www.example.org]]
  2. <a href="/projects/redmine/wiki/www" class="wiki-page new">www.example.org</a>

This might be solved by reordering rendering methods in source:trunk/app/helpers/application_helper.rb#L453 in a way that parse_wiki_links runs before inline_auto_link. Maybe, these methods need to be included into the textile implementation in source:trunk/lib/redmine/wiki_formatting/textile in the correct ordering.

#2 Updated by Jean-Philippe Lang over 11 years ago

Redmine links (eg. wiki, ticket links...) should not be handled by the builtin text formatter so we can easily switch to another one.

Maybe we could fix inline_auto_link instead.

#3 Updated by Go MAEDA almost 4 years ago

This issue seems to be fixed in Textile. I could not reproduce on Redmine 3.4.6.devel.17477. But it still does not work as expected in Markdown.

#4 Updated by Alejandro Mery almost 4 years ago

  • Status changed from New to Resolved

Go MAEDA wrote:

This issue seems to be fixed in Textile. I could not reproduce on Redmine 3.4.6.devel.17477. But it still does not work as expected in Markdown.

8 years! amazing. I thought redmine was long dead, feel free to close the ticket.

#5 Updated by Go MAEDA almost 4 years ago

  • Status changed from Resolved to New

Also available in: Atom PDF