Project

General

Profile

Actions

Patch #7071

closed

plugin settings partial path collision

Added by Erik Ordway about 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Category:
Documentation
Target version:
-
Start date:
2010-12-07
Due date:
% Done:

0%

Estimated time:

Description

So for plugins that use
app/views/settings/_setting.*
for the site with plugin configuration have a collision caused by having the same path. This path is configured via
settings :default => {'bbb_server' => ''}, :partial => 'settings/settings'
as an example.

multiple plugins use this (the older CAS one and the newer bigbluebox plugin for example) do this. Because of this you can not get to the BBB configuration as the CAS _settings partial loads instead.

There are two options to fix this.
The first is to rename
app/views/settings/_setttings.*
to
app/views/settings-bbb/_settings.*
and
change the
settings =>
as needed

The other option is to change the name of the partial and the settings => as needed.

I have done the first and not tested the latter although it maybe the better solution.

SUGGESTION:
Note in the plugin development documentation the preferred way of doing this.

Actions #1

Updated by Mischa The Evil about 13 years ago

  • Category set to Documentation
Actions #2

Updated by Rocco Stanzione over 12 years ago

Surely it's possible to prevent this conflict within Redmine? I've run into this several times and only just now realized the cause of the problem. +1.

Actions #3

Updated by Jean-Baptiste Barth almost 11 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Baptiste Barth

Added a note in Plugin_Tutorial, and I also think there should be a visible warning about that, so I opened #14008 for future implementation. I close this one.

Actions

Also available in: Atom PDF