Defect #7172

{{toc}} macro doesn't work with <pre></pre>

Added by TANUKI M almost 12 years ago. Updated almost 12 years ago.

Status:ClosedStart date:2010-12-25
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Fixed Affected version:

Description

In my environment (1.0.5), {{toc}} doesn't render headers after <pre></pre>.

h1. aaa

{{>toc}}

etc

h2. bbb

<pre>
</pre>

h2. ccc

etc

h2. ddd

ccc , ddd don't appear.

aaa
  bbb


Related issues

Duplicated by Redmine - Defect #7183: Svn 4376 breaks table of contents with pre's Closed 2010-12-27

Associated revisions

Revision 4578
Added by Jean-Philippe Lang almost 12 years ago

Fixed: partial toc when text contains pre tags (#7172).

History

#1 Updated by Felix Schäfer almost 12 years ago

Can't reproduce, could you try on the http://demo.redmine.org if it behaves as intended or not?

#2 Updated by Felix Schäfer almost 12 years ago

  • Status changed from New to Closed

Already reported in #7172, thanks nontheless.

#3 Updated by Felix Schäfer almost 12 years ago

  • Status changed from Closed to Reopened

Sorry, got the relation in the wrong order.

Anyway, I was able to confirm this on my local devel environment.

#7183 holds a little more info, especially which commit probably broke this.

#4 Updated by Jean-Philippe Lang almost 12 years ago

  • Status changed from Reopened to Closed
  • Resolution set to Fixed

The diagnostic in #7183 was correct. Fixed with test in r4578.

Also available in: Atom PDF