Project

General

Profile

Actions

Feature #7557

closed

Deny editing of descriptions of closed issues

Added by Ве Fio about 13 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues permissions
Target version:
-
Start date:
2011-02-05
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

When a project is marked as "closed" I think it'd be a reasonable default to deny editing the description.

As there's no history for the description this would allow opening editing to restriced roles until the task is finished - while denying it afterwards.


Related issues

Related to Redmine - Patch #7444: Patch for improved issue edit permissionsClosedBrian Lindahl2011-01-25

Actions
Related to Redmine - Patch #2685: Display notice when commenting on closed ticketsNew2009-02-06

Actions
Related to Redmine - Feature #13814: No more comments when ticket closedNew

Actions
Is duplicate of Redmine - Feature #3521: Permissions for roles to change fields per tracker/statusClosedJean-Philippe Lang2009-06-22

Actions
Actions #1

Updated by Etienne Massip about 13 years ago

  • Tracker changed from Defect to Feature
Actions #2

Updated by Brian Lindahl about 13 years ago

Similar feature implemented in patch #7444:
subjects/descriptions are denied editing once the issue has been assigned (once the workflow has begun)

Note that this patch also implements other issue permissions.

Actions #3

Updated by Ве Fio about 13 years ago

Interesting. Our typical workflow is to assign the issue beforehand and start ("In Progress") it later.

Thus #7444 "edit the issue until the issue has been assigned." won't be applicable.

The main use case would be:
Deny lower priviledged users to change history.

The desriptions of maybe long past issues would be preserved in the state they were when "Closed".

Actions #4

Updated by Brian Lindahl about 13 years ago

How can an issue be 'In Progress' without someone working on it (assigned to someone)? I can't see how that makes sense.

Actions #5

Updated by Ве Fio about 13 years ago

Brian Lindahl wrote:

I can't see how that makes sense.

It doesn't ;)

As stated we first assign the issue and set it to "In Progress" later.

Actions #6

Updated by Brian Lindahl about 13 years ago

Ahh, I misread. Probably due to the confusion in that once an issue is assigned, we consider the workflow to be started (at least someone besides the author has taken note of the issue). Rather than your team, where it appears that you consider the workflow to be started once someone is actively working on it (In Progress).

Actions #7

Updated by Jean-Philippe Lang over 11 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Implemented as part of #3521 for 2.1.0. You can now make the description read-only for a given status.

Actions

Also available in: Atom PDF