Project

General

Profile

Actions

Defect #9131

closed

Link to attachment broken in notification email at issue creation

Added by pasquale [:dedalus] over 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
2011-08-26
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

When add\edit issue with attachments, redmine should be save first attachment list and only after sending mail notification: now if I add an attachment with clickable link (for example attachment:file.txt) in mail notification the link isn't clickable because I suppose that file isn't already saved into attachments folder.

This is very annoying bug


Related issues

Is duplicate of Redmine - Feature #2770: Display of inline attached images in email notificationReopened2009-02-18

Actions
Actions #1

Updated by pasquale [:dedalus] over 12 years ago

xref bug #2770

Actions #2

Updated by Etienne Massip over 12 years ago

  • Subject changed from When add\edit bug with attachments, first save attachments and after send mail notification to Link to attachment broken in notification email at issue creation
Actions #3

Updated by Etienne Massip almost 11 years ago

  • Status changed from New to Needs feedback
  • Priority changed from High to Normal

Looking at the code I'm not sure this is true anymore, could you confirm?

Actions #4

Updated by Fernando Hartmann almost 11 years ago

Etienne Massip wrote:

Looking at the code I'm not sure this is true anymore, could you confirm?

In my Redmine 2.2.3 the links are working, if I click over the link the browser open and the attached file is showed.
But #2770 is steal there ..

Actions #5

Updated by Etienne Massip almost 11 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Agreed.

Actions

Also available in: Atom PDF