Project

General

Profile

Unable to change the language for not logger users

Added by Baptiste Wicht almost 14 years ago

Hi,

I've a little problem with my installation of Redmine. The language of the interface before log in is always in English but i've set the default language to French.

Is there a way to specify that the language must be French for anonymous users ?

If that could help, the site is here.

Thanks

Baptiste


Replies (5)

RE: Unable to change the language for not logger users - Added by Felix Schäfer almost 14 years ago

This is expected behavior: redmine looks at the headers the browser sends to try to determine the language the user runs the browser in, the Default Language setting (RedmineSettings) is only the fallback redmine uses if it can't determine the language of the user.

As to the direct question: no simple way I'd know of to make redmine show the french interface to every anonymous user.

RE: Unable to change the language for not logger users - Added by Baptiste Wicht almost 14 years ago

Ok, i didn't understand that settings like that.

Thank you very much.

RE: Unable to change the language for not logger users - Added by Mischa The Evil almost 14 years ago

Felix Schäfer wrote:

[...]

As to the direct question: no simple way I'd know of to make redmine show the french interface to every anonymous user.

Maybe patch #2691 might provide some help...

RE: Unable to change the language for not logger users - Added by Baptiste Wicht almost 14 years ago

Interesting, thanks.

I will see that patch :)

RE: Unable to change the language for not logger users - Added by Brian Ravnsgaard Riis over 13 years ago

Has this stalled? I think this option is almost essential, actually.

Mischa, thanks for the patch. :-) This has been bugging me since I started with Redmine.

/Brian
    (1-5/5)