SVN authentication fails

Added by Luis Schaab over 10 years ago

Hello, Im trying to configure Redmine to work with Subversion.
I have followed this HowTo: http://www.redmine.org/projects/redmine/wiki/Repositories_access_control_with_apache_mod_dav_svn_and_mod_perl

Im using a CentOS 5.4 server, with Apache 2.2.3 and Subversion 1.6.13. Redmine is installed on the same server.

My subversion.conf is:

    LoadModule authz_svn_module   modules/mod_authz_svn.so

    # /svn location for users
    PerlLoadModule Apache::Redmine

    <Location /svn>
    DAV svn

    SVNParentPath "/var/svn" 
    Order deny,allow
    Deny from all
    Satisfy any

    PerlAccessHandler Apache::Authn::Redmine::access_handler
    PerlAuthenHandler Apache::Authn::Redmine::authen_handler
    AuthType Basic
    AuthName "Redmine SVN Repository" 

    #read-only access    
    <Limit GET PROPFIND OPTIONS REPORT>
       Require valid-user
       Allow from IP-FROM-SERVER
       # Allow from another-ip
       Satisfy any
    </Limit>

        # write access
    <LimitExcept GET PROPFIND OPTIONS REPORT>
       Require valid-user
    </LimitExcept>

        RedmineDSN "DBI:Pg:dbname=redmine;host=localhost" 
    RedmineDbUser "redmine" 
    RedmineDbPass "xxxxxxx" 
    </Location>

It keeps on prompting the login window over and over. Can you help me please? I'ma little lost...

Replies (2)

RE: SVN authentication fails - Added by Jim McAleer over 10 years ago

Did you add a user to the project repository? The admin is not added by default either.

RE: SVN authentication fails - Added by Pierre BLONDEAU over 10 years ago

In my server, for SVN in <Location /svn>

I must have :

Allow from all

It seem not to be security vulnerability because the Limit directive disable repository access for every body.

I haven't the same problem with GIT.

Can you try to add it in you configuration instead of ? :

Order deny,allow
Deny from all
Satisfy any

And if anyone can tell me why we need this, I am interested.

Regards

(1-2/2)