redmine_wk_time install problem !

Added by Kamil AFACAN 7 months ago

I installed this plugin Redmine 4.1.0-8.
During the bundle install I got some warnings. Due to I am a brand new user of Redmine, I could not comment. Continue to migrate.
Now I could not enter some settings. I am sure but I don't how to configure this kind of warnings !
One of them is below. There a lot gem files mentioned like this.

Warning: the gem 'et-orbi' was found in multiple sources.
Installed from: http://rubygems.org/
Also found in: * https://rubygems.org/
You should add a source requirement to restrict this gem to your preferred sourc
e.
For example:
gem 'et-orbi', :source => 'http://rubygems.org/'
Then uninstall the gem 'et-orbi' (or delete all bundled gems) and then install a
gain.

Any help will be appreciated.

wk_time_fault.txt Magnifier (4.53 KB)

Replies (30)

RE: redmine_wk_time install problem ! - Added by Liane Hampe 7 months ago

Hello Kamil,

Probably, you have some other plugins installed which require the same gems as redmine_wk_time.

You should ask the plugin authors to specify the version of the required gems. This might resolve your warning when all plugins can use the same version.

If there still remain conflicts between gems, then you need to uninstall one of the respective plugins due to incompatibility.

Best Regards,
Liane

RE: redmine_wk_time install problem ! - Added by Amutha R 7 months ago

-I think it is giving a warning about gems source. some plugins are saying source is http://rubygems.org/ while some others are saying https://rubygems.org/

-Installed of installed all plugins from the plugins folder, you could go to the individual plugin folder and install them separately or open the Gemfile and change the source to https://rubygems.org/

Thanks & Regards,
Amutha.R

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Thanks for the quick response first of all.
I am really new to this program and I am a mech engineer. I am a project management position and dealing all of them alone. When I searched the plugins folder I couldn't find it. This is very easy question but I am just at that point in which file should I look at it?

Thanks in advance

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

I found the files and download th correct ones. I installed this plugin to a new redmine installation. But this plugin somehow does not permit to see any settings even the My Account page. I am surprised. I can configure the plugin that is all.
What may be the reason?

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

can you post screen shot ?
and also can you see your <redmine>/log/production.log file and see if you are getting any errors ?
what version of redmine and erpmine do you have ?

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Hi Mr Krishnapandian
I want to express first of all appreciation about this plugin.
I am confused a little bit. As I try to explain in mail also, I am using Redmine 4.1.0-8. Bitnami Stack. )(version.jpg)

When I run bundle install command I got some warnings. (wk_time_fault.txt)
I go the rubygems.org and install all mentioned gemss manually from the site.
Ten the result is as I explained either thin servers stop and I could not restart even manually from the windows menu / the Bitnami tool or works but does not permit to enter any settings. (Production.log)

Thanks in advance

version.jpg - Version that I used (26 KB)

wk_time_fault.txt Magnifier - Warning (4.53 KB)

production_0.log (289 KB)

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

The versioin.jpg doesn't say which version of erpmine you have
The bundle install actually went through fine, it says bundle complete
The production log has references of erpmine being installed, it has no errors, what exactly is the problem you are facing ?

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

I downloaded the plugin from this site, the master branch.
https://github.com/dhanasingh/redmine_wktime

I will install one more time on a new installed redmineplusagile. I will take some screenshots.

But let me clarify something. When the bundle warn me to change the source, to correct them I downloaded the gem files directly from rubygems.org. But nothing changed.

Why I am asking, in one trial I download the gem files before plugin installation and I got no warning.
Is it correct? However the result is the same.

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

installing the gems before the plugin install is ok

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

whenever you get a internal error, just check the production log and see what the actual error is and send us

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

I upload the production.log, error.log.

Also you may find the video what I did to install.

https://www.youtube.com/watch?v=hXFrhE0CvYo

production.log (117 KB)

error.log (14.1 KB)

RE: redmine_wk_time install problem ! - Added by Amutha R 7 months ago

I think what you did just before copying the db is fine. The moment you copy the old db over the new migrated db, we have a problem with users table.

So if you want your old db, then start fresh from your old db and migrate on to it.

Thanks & Regards,
Amutha.R

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Hi Mr Amutha
Thank you very much for your response and effort. When I start to this program I learned this way of backing up and loading back again. Also when I backup the data I have problem thinservers stops and I never restart again. At this situation I am stopping all servers fromthe tool. Delete the folder completely and unzip the complete folder which is zipped before without any data.

The commands which I use to get data backup and load as below.

Backup
mysqldump -A -u root -p > backup.sql

Upload
mysql -u root -p -D bitnami_redmine < backup_red_0426.sql

What is the mistake?

I will search for another method to migrate the database on Windows.

Thank you very much.

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Hi

This data upload method cause another plugin fail also yesterday. Redmine_indicator. After uploading the data some custom areas were deleted.

Sorce of the commands
https://docs.bitnami.com/installer/apps/redmine/administration/backup-restore-mysql-mariadb/

For your information.

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

When you do a db_migrate it actually updates the db.
So you should restore the db first and then do db_migrate

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

I thnink I could not explain. I have a backup file from server. I am installing first on a laptop to check the availability. Laptop installation is new. I upload the plugins and then upload the data. I also try the vice versa first data and the plugin.

But both of them failed.

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

data should be uploaded first and then the plugins, what error are you getting ?

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Here is the results in the file. Screenshots in one word file. The others are logs.

WK_INS_LOGS.7z (381 KB)

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

looking at the production log file, the following lines say, the erpmine plugin is installed correctly
Do you see erpmine as one of the plugins listed under admin ?

Migrating to CreateWktimes (1)
Migrating to CreateWkExpenseEntries (2)
Migrating to CreateWkAttendances (3)
Migrating to CreateWkSalaryComponents (4)
Migrating to CreateWkBilling (5)
Migrating to CreateWkAccounting (6)
Migrating to CreateWkCrm (7)
Migrating to CreateWkPayment (8)
Migrating to CreateWkPurchase (9)
Migrating to CreateWkInventory (10)
Migrating to CreateWkAssetManagement (11)
Migrating to CreateWkScheduling (12)
Migrating to CreateWkResidentManagement (13)
Migrating to UserSupervisor (14)
Migrating to CreateWkSurvey (15)
Migrating to SettingsPermission (16)
Migrating to CreateWkSurveyReview (17)
Migrating to ChangeWkInventoryItem (18)
Migrating to CreateWkLeaveRequest (19)
Migrating to CreateWkIncomeTax (20)
Migrating to AddAuthorIdToExpenseEntries (21)

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Plugin is being installed correctly. I know.
Problem is;
When I install plugin while the system does not have any data; as an admin I can see all of the ERPmine features. After uploading the data, settings menu for the projects (I need to configure) shows blank page.

When I install data first and upload the plugin later, thinservers stops and couldn't restart the servers. I have to install again the redmine completely.

I know it is mysterious.

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

I don't see any errors in the log files. So can't say why the server wouldn't start.
Can you check if the webrick server would start. Stop the production server and try this

go to the redmine folder and run this command

rails s -e production

This should start the webrick server, it will listen in port 3000

you should be able to access the app http://localhost:3000/

do a ctrl c to exit

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

I appreciate for your efforts today last time I try your suggestion and tried to upload the plugin one more time. Result is in the attachment. Tomorrow I will install again. Just I will upload this plugin and then data.

I will inform you also.

Thank you very much.

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

then try this command

bundle exec rails server webrick -e production

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Hello

I installed from the beginning and I copied all I did inside attachment file. I am keeping also the other version.
When I face a thinserver prblem I will try this comment.

Last situation explained in the attachement. (due to the limit, splitted into 2 files)

Thanks again.

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Dhanasingh Krishnapandian wrote:

then try this command

bundle exec rails server webrick -e production

I tried and copied the result in the attached file.

1 2 (1-25/30)