Feature #13512

Add a way to make specific issues visible to a user

Added by Kyle Leber about 7 years ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:-
Resolution:Duplicate

Description

I have a role defined with issue visibility set to "Issues created by or assigned to the user". It would be great if I can make a certain issue visible to that user by adding them as a watcher. As it is, they can't see any pre-created issue without me assigning it to them.


Related issues

Related to Redmine - Feature #13511: Add a way to restrict access to the "Activity" feed for a... New
Related to Redmine - Feature #12666: Involvement boolean for Custom Field 'User' type New
Related to Redmine - Defect #22977: A project member has no access and gets no notification, ... New
Duplicates Redmine - Feature #8488: Create an 'Involve' mechanism to private issues New

History

#1 Updated by Kyle Leber about 7 years ago

Sorry, forgot this:

Environment:
Redmine version 2.0.3.stable
Ruby version 1.8.7 (x86_64-linux)
Rails version 3.2.6
Environment production
Database adapter MySQL
Redmine plugins:
redmine_mylyn_connector 2.8.2.stable

#2 Updated by Daniel Felix about 7 years ago

Maybe there could be a new permission? But I'm not sure.

A better way would be to give the user the ability to set a special user who has certain permissions?

#3 Updated by Anonymous about 7 years ago

I think this is essentially the same as #8488. Though that issue was looking to extend visibility for private issues, in practice we're talking about the same action--a new kind of involvement in addition to author/assignee.

It also somewhat relates to one of my own feature requests (selfplug+10!), #12666, for this to be part of configuring the user-type custom field. Specifically, an optional check box when setting up a custom field that, when checked, means the user(s) selected in the list are involved in the issue.

Permissions don't really need to be any more complex than existing workflow tools.

#4 Updated by Alexis Parent over 4 years ago

+1

#5 Updated by Pavel Konstantinov over 4 years ago

+1 required for me too

#7 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Defect #22977: A project member has no access and gets no notification, when being a watcher of the issue added

#8 Updated by Marius BALTEANU about 1 month ago

  • Related to deleted (Feature #8488: Create an 'Involve' mechanism to private issues)

#9 Updated by Marius BALTEANU about 1 month ago

  • Duplicates Feature #8488: Create an 'Involve' mechanism to private issues added

#10 Updated by Marius BALTEANU about 1 month ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing this as duplicate of #8488 where we can track a method to achieve this without using the existing watchers functionality because according to Jean-Phillippe Lang's comment from #7412#note-13:

watchers were designed for notification purpose only. A user who unwatches a private issue would lost access to it. It may be quite confusing for many users.

Also available in: Atom PDF