Feature #13891

Field conditions depending on ticket status

Added by Jörn Allmers almost 7 years ago. Updated almost 4 years ago.

Status:Needs feedbackStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Conditions for ticket fields should be depending on the status of the ticket.
E.g. Date may be null if ticket is new but not is ticket is resolved.


Related issues

Related to Redmine - Defect #12146: Required (list-, user- or version) custom field "fixed ve... Confirmed

History

#1 Updated by Filou Centrinov almost 7 years ago

What's about field permission (workflow settings)?

#2 Updated by Filou Centrinov almost 7 years ago

Status: Needs feedback

#3 Updated by Mischa The Evil almost 7 years ago

  • Status changed from New to Needs feedback

#4 Updated by Jörn Allmers almost 7 years ago

This feature solves the problem only partly.
It would be cool if I could say something like "% done" must not be null and 100% if the state is closed.

#5 Updated by @ go2null about 4 years ago

Jörn Allmers: E.g. Date may be null if ticket is new but not is ticket is resolved.

Filou Centrinov: What's about field permission (workflow settings)?

The issue is that you cannot say that the Date must be entered before the issue can be closed, and must be read-only when it is closed.
  • If I set the field to "Required" for status Closed, then it can be changed when it is in status Closed.
  • If I set it to "Read-Only", then it can be set to blank when closing.

Workaround is that for all Statuses that can lead to a closed Status, you will need to set the field to "Required".

#6 Updated by @ go2null almost 4 years ago

Duplicate of #12146

#7 Updated by @ go2null almost 4 years ago

Duplicate of Feature #9280

#8 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Defect #12146: Required (list-, user- or version) custom field "fixed version" with Multiple values allows nil value during status transition added

Also available in: Atom PDF