Defect #30359

Time entries of subtasks in other projects are not listed

Added by Go MAEDA over 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate Affected version:

Description

When you click a link on the spent time value, you can see a list of time entries of subtasks.

But if the parent issue has subtasks from other projects, time entries from those issues don't appear on the list.

The attached patch fixes the problem.


Parent issue:

Issue 18 has two subtasks. Issue 19 is in the current project but issue 20 is in another project. You may think that you can see time entries of those two subtasks if you click the spent time value ("16.50 h").

Before:

However, in Redmine 4.0.0, you cannot see time entries of issue 20 because the project is in the different project. It is confusing.

After:

After applying the patch, time entries of issue 20 are shown as well. I think this is desirable behavior.

parent-issue@2x.png (59 KB) Go MAEDA, 2019-01-08 09:09

time-entries-before.png (25.1 KB) Go MAEDA, 2019-01-08 09:14

time-entries-after.png (30 KB) Go MAEDA, 2019-01-08 09:18

spent-time-fix.diff Magnifier - patch (559 Bytes) Go MAEDA, 2019-01-08 09:28


Related issues

Duplicates Redmine - Defect #29312: Spent time report does not show all logged time entries w... New

History

#1 Updated by Erick Joel Acuña Cotrina over 3 years ago

  • File 49202831_10157230565184658_8001696240507027456_n.jpg added

#2 Updated by Marius BALTEANU over 3 years ago

  • File deleted (49202831_10157230565184658_8001696240507027456_n.jpg)

#3 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #29312.

#4 Updated by Go MAEDA about 2 years ago

  • Duplicates Defect #29312: Spent time report does not show all logged time entries with parent task in different projects added

Also available in: Atom PDF