Drop Ruby < 2.5 support
|Assignee:||Go MAEDA||% Done:|
Rails 6 requires at least Ruby 2.5.0
root@85be5e8d7c3e:/work# bundle update The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`. Fetching gem metadata from https://rubygems.org/.......... Fetching gem metadata from https://rubygems.org/. Resolving dependencies... Bundler could not find compatible versions for gem "ruby": In Gemfile: ruby rails (= 6.0.0.beta3) was resolved to 6.0.0.beta3, which depends on ruby (>= 2.5.0)
- File 0001-Drop-Ruby-2.5-Support.patch added
- File 0002-Update-TargetRubyVersion-of-RuboCop-to-2.5.patch added
The attached patches drop Ruby 2.4 support.
As Marius wrote, Rails 6 requires Ruby 2.5 or later. We have to migrate to Rails 6 in Redmine 5.0 because the support for Rails 5.2 which we are currently using will end when Rails 7.0 (the next version of Rails) is released.
And Ruby 2.4 has already become EOL in March 2020.