Defect #32913

Rails 6: add filename header

Added by Pavel Rosický over 1 year ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Rails support
Target version:-
Resolution:Fixed Affected version:

Description

fixes

WikiControllerTest#test_show_versioned_txt [/redmine/test/functional/wiki_controller_test.rb:1133]:
--- expected
+++ actual
@@ -1 +1 @@
-"attachment; filename=\"CookBook_documentation.txt\"" 
+"attachment; filename=\"CookBook_documentation.txt\"; filename*=UTF-8''CookBook_documentation.txt" 

wiki_controller_test.rb.patch Magnifier (2.61 KB) Pavel Rosický, 2020-01-29 01:33


Related issues

Related to Redmine - Feature #29914: Migrate to Rails 6.1 New

Associated revisions

Revision 20891
Added by Go MAEDA 4 months ago

Add filename header (#29914, #32913).

Patch by Pavel Rosický.

Revision 20901
Added by Go MAEDA 4 months ago

Fix a test failure caused by an assert forgotten to be deleted (#29914, #32913).

History

#1 Updated by Marius BALTEANU over 1 year ago

#2 Updated by Go MAEDA over 1 year ago

  • Category set to Rails support

#3 Updated by Marius BALTEANU 4 months ago

  • Tracker changed from Patch to Defect

#4 Updated by Go MAEDA 4 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch as a part of #29914.

Also available in: Atom PDF