Defect #33170

Login problem - error with certificate

Added by Forall Forall over 2 years ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:No feedback Affected version:4.1.0

Description

Hello,

I upgrade my redmine to the latest version 4.1.0 on debian 10.3 with ruby-2.7.0-preview1.

An error occurred when authenticating: SSL_connect returned=1 errno=0 state=error: certificate verify failed (unable to get local issuer certificate)

Screenshot from 2021-10-14 15-03-11.png (12.1 KB) Pierre de LESPINAY, 2021-10-14 15:03

ldaps.png (12.1 KB) Pierre de LESPINAY, 2021-10-14 15:06

History

#1 Updated by Go MAEDA over 2 years ago

Perhaps it is related to #24970 and #29606. Could you try the following steps?

1. Backup your Redmine's database
2. Connect to the database with a command line client such as mysql or psql
3. Run the following SQL.

update auth_sources set verify_peer=false;

#2 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to No feedback

#4 Updated by Pierre de LESPINAY 9 months ago

I had this issue, this update solved it.
But just using the option "LDAPS without certificated check" solved it too.
So no need to do the SQL update for me.

Also available in: Atom PDF