Defect #33402

Receive email problem - inserting unwanted p tags

Added by Andrej Simko about 1 year ago. Updated 7 months ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-
Resolution: Affected version:4.1.1

Description

I have problem with receiving emails after upgrading to the latest stable version 4.1.1.

Even if I have setup that email should be parsed as plain text, issues are created with the text and there are unwanted <p> </p> tags even if I setup text formatting to none or textile or markup.

This happens after updating to the version 4.1.1 from 3.4.13.

This is my environment:

Environment:
  Redmine version                4.1.1.stable
  Ruby version                   2.5.3-p105 (2018-10-18) [x86_64-linux]
  Rails version                  5.2.4.2
  Environment                    production
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                smtp
SCM:
  Subversion                     1.9.5
  Mercurial                      4.8.2
  Cvs                            1.12.13
  Bazaar                         2.8.0
  Git                            2.20.1
  Filesystem                     
Redmine plugins:
  issue_color_label              0.1
  localizable                    0.4.0
  redmine_agile                  1.5.3
  redmine_checklists             3.1.16
  redmine_ckeditor               1.2.3
  redmine_contacts               4.3.0
  redmine_contacts_helpdesk      4.1.8
  redmine_contacts_invoices      4.2.3
  redmine_crm_mailchimp          1.0.4
  redmine_custom_js              0.1.0
  redmine_dmsf                   2.4.2
  redmine_finance                2.1.7
  redmine_per_project_formatting 0.1.0
  redmine_products               2.1.2
  redmine_questions              1.0.2
  redmine_reporter               1.0.3
  redmine_silencer               0.4.1
  redmine_smile_togglesidebar    1.0.7
  redmine_theme_changer          0.4.0
  redmine_zenedit                1.0.3

I receive emails from gmail.

This is a test email:

safsad sa

 f

fdsa

a

fdsa

fsd

as

This is a issue created:

<p>safsad sa</p>

<p> f</p>

<p>fdsa</p>

<p> </p>

<p>a</p>

<p>fdsa</p>

<p>fsd</p>

<p> </p>

<p>as</p>

Can somebody help me where could be a problem?

History

#1 Updated by Andrej Simko about 1 year ago

I forgot to mention, that even I have setup email receiving for plain text, if I debug the code, it always handle it with html_body_to_text function in mail_handler.rb ... but I dont know where to look else for now.

#2 Updated by Gaƫl CORDON 12 months ago

Hello @Andrej

did you manage to figure out what was wrong.
I've got exactly the same issue.

Environment:
Redmine version 4.1.1.stable
Ruby version 2.5.5-p157 (2019-03-15) [x86_64-linux-gnu]
Rails version 5.2.4.2
Environment production
Database adapter Mysql2
Mailer queue ActiveJob::QueueAdapters::AsyncAdapter
Mailer delivery smtp
SCM:
Git 2.20.1
Filesystem
Redmine plugins:
additionals 2.0.23
easy_mindmup 1.0
easy_wbs 1.5
redmine_ckeditor 1.2.3
redmine_contacts 4.3.0
redmine_contacts_helpdesk 4.1.8
redmine_dashboard 2.7.1
redmine_messenger 1.0.6
redmine_monitoring_controlling 0.1.1
redmine_my_page 0.1.13

#3 Updated by Go MAEDA 7 months ago

Is the issue reproducible without plugins?

Also available in: Atom PDF